Google Play Services не работает на Android-эмуляторе API уровня 11

Я разрабатываю приложение, которое использует Карты Google, но каждый раз, когда я перехожу к деятельности карты, выдает это сообщение: This app won't run without Google PLay services, which are missing from your phone . Я использую API Google (Google Inc.) – уровень API 11. Он должен работать, потому что это системный образ с сервисами Google Play.

Я использую Android Studio и использую com.google.android.gms:play-services:+ зависимости. Может ли кто-нибудь сказать мне, есть ли что-то, что мне не хватает?

Спасибо!

Я решил свою проблему: я создал новое виртуальное устройство Android, но не с API Google, но Android API 11.

Я должен был установить вручную Google Play Services и Google Play Store, но не используя API Google через командную строку.

Это было полезно для меня:

Настройка эмулятора Android для запуска Google Map v2

И это:

Android Google Maps API V2 запускается в эмуляторе и запускается на уровне API 10 или 9 или 8 или Android 2 3 3

На устройстве должно быть установлено приложение Google Play.

Вы можете проверить, установлен ли этот телефон / устройство / эмулятор, используя это: http://developer.android.com/reference/com/google/android/gms/common/GooglePlayServicesUtil.html#isGooglePlayServicesAvailable(android.content.Context )

Похоже, что услуги Google Play не поддерживаются эмулятором: как загрузить сервисы Google Play в эмулятор Android?