Невозможно использовать forEach и лямбда в android min sdk версии менее 24

Я использую jack компилятор в моем проекте Android. Мой min sdk установлен в 18. Я не могу использовать forEach и лямбда в моем коде. Он просит меня изменить мой min sdk на 24 или выше. Я надеялся, что с интеграцией JACK-компилятора я смогу использовать этот forEach с лямбдой легко. Есть ли какая-нибудь работа для этого, кроме того, что натыкается на min sdk?