Можете ли вы изменить мин. API для вашего приложения Android в Eclipse?

Я выбрал API минимального уровня 1.5 для моего приложения для Android, и я собираюсь интегрировать в него жесты, которые пришли в 1.6. Есть ли способ в Eclipse изменить минимальный уровень с 1,5 до 1,6 на полпути через создание приложения?

Большое спасибо

Если вы зашли в свой файл манифеста и установили

<uses-sdk android:minSdkVersion="3" /> 

в

  <uses-sdk android:minSdkVersion="4" /> 

Затем вы смените весь проект на 1,5, как минимум, на 1,6.

Пока вы все еще создаете свое приложение, вы можете в любой момент изменить минимальный уровень API.

Используя Android Studio, вы найдете minSdkVersion в файле minSdkVersion в build.gradle app .

Ответы на uses-sdk больше не верны в Intellij.

Теперь <uses-sdk> игнорируется в AndroidManifest.xml, он автоматически добавляется к встроенному файлу манифеста. Чтобы изменить версию, перейдите в файл build.gradle и посмотрите на minSdkVersion.

Да, перейдите к манифесту и измените <uses-sdk android:minSdkVersion="3" /> на <uses-sdk android:minSdkVersion="4" /> . Затем перейдите в Project> Properties> Android и измените Project Build Target на 1.6, чтобы распознать новый код API, введенный в 1.6.

Измените следующую строку в файле AndroidManifest.xml

  <uses-sdk android:minSdkVersion="8" /> 

Просто подумайте о minSdkVersion как о вашем целевом номере API.

Имейте в виду, что это может привести к тому, что некоторые старые устройства не будут запускать ваше приложение.

В Intellij версии Android Studio вы можете просто перейти к Gradle Scripts> build.gradle (Module: app), а затем изменить эту строку

MinSdkVersion 12

К числу желаемых версий.

В Android Studio вы найдете файл minSdkVersion / targetSdkVersion в файле build.gradle (module: app) в каталоге Gradle Scripts. Отредактируйте версию сборки здесь, а затем откройте файл манифеста, чтобы синхронизировать сделанные изменения.