Запуск Android-проекта с помощью PhoneGap

Я пытаюсь запустить Android-приложение с помощью PhoneGap. Я следую видео YouTube, и когда я нажимаю кнопку запуска, он показывает мне следующие ошибки.

12-03 18:45:52.704: E/AndroidRuntime(27214): java.lang.RuntimeException: Unable to start activity ComponentInfo{tpl.apps.UKTrains/tpl.apps.UKTrains.Main}: android.content.res.Resources$NotFoundException: Resource ID #0x0 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2705) 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2721) 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.app.ActivityThread.access$2300(ActivityThread.java:132) 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2071) 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.os.Handler.dispatchMessage(Handler.java:99) 12-03 18:45:52.704: E/AndroidRuntime(27214): at android.os.Looper.loop(Looper.java:123) 

Затем я попытался запустить приложение для примера с информацией о телефоне и материалами. Он работает нормально, и я сделал некоторые другие изменения в соответствии с образцом приложения, но он все еще не работает.

Вы хоть представляете, что это может быть? Благодарю.

Я просто подтверждаю, что Онур уже написал: есть файлы phonegap.xml (называемые cordova.xml прямо сейчас, после того, как Phonegap стал проектом Apache Cordova) и plugin.xml, и вы продолжаете получать ошибку выше, пока не предоставите эти два файла в res / Xml.

Я столкнулся с проблемой при клонировании моего проекта Phonegap, созданного с выпуском 0,9, и обновления файлов Phonegap до 1,2 или Cordova 1.5.

Очевидно, я не уделял достаточного внимания файлам «changelog», потому что не было файлов XML, необходимых для выпуска 0.9x.