Ошибка Android Lint: для класса требуется уровень API 3, ток – минус 1

При запуске моего приложения для Android я часто получаю список ошибок, которые говорят

Class requires API level 3 (current min is 1): android.hardware.SensorEventListener 

Я искал правильный ответ на этот вопрос, например, инструменты Android> Clear Link Markers, но это не решает проблему. Время от времени список ошибок продолжает возвращаться. Это что-то в моих настройках проекта или мои устаревшие методы? Я установил последнюю версию SDK для Android 4.4.

В вашем файле manifest установите sdk, как это, исходя из вашего требования.

  <uses-sdk android:maxSdkVersion="17" android:minSdkVersion="8" /> 

Измените приложение minsdk из « Preference>Android>select the api level Android1.6

Intereting Posts
Разрешить многострочный просмотр в режиме EditText в Android? Создание EditText и Button одинаковой высоты в Android SlidingMenu (jfeinstein). Отключить только вторичное меню Различное поведение для FillType.EVEN_ODD при добавлении CornerPathEffect? Android: как масштабировать изображение, чтобы заполнить фон LinearLayout без сохранения соотношения сторон? Служба Android не запускается FindViewById возвращает значение null для WebView Что происходит с сообщением «Неожиданное возобновление сообщения <packagename> в то время как уже возобновлено» на Android? Почему эмулятор дает номер IMEI 000000000000000 Как передавать данные между различными приложениями Android? Почему между CardViews на Lollipop нет места? Как настроить интерфейс диалогового окна, возвращенного из GooglePlayServicesUtil.getErrorDialog? Android auto copy Proguard для сопоставления Android Studio Как создать соединение с Socket в Android? Количество GPS-спутников и фильтрация местоположения