Приложения Android в ошибке запуска Eclipse

Я не могу понять, что происходит с моей Eclipse IDE. Я разрабатываю несколько приложений, и я обновил свой Android SDK и обновил Eclipse, и теперь я не могу запускать ни одно из моих приложений. Каждое приложение (в том числе API Demos, так что это не только мое) не запускается, и Eclipse говорит: «В вашем проекте содержатся ошибки, пожалуйста, исправьте их перед запуском приложения».

Я не могу найти причину этой ошибки, и мои приложения запускались раньше, и это только началось. Я думал, что обновление Android SDK поможет, но это все равно дает мне эту ошибку для любого приложения, которое я пытаюсь запустить. Пожалуйста помоги! Что я делаю? Единственная ошибка, которую я видел, такова:

[2012-06-21 13:37:19 - ddmlib] Broken pipe java.io.IOException: Broken pipe at sun.nio.ch.FileDispatcher.write0(Native Method) at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:29) at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:69) at sun.nio.ch.IOUtil.write(IOUtil.java:40) at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:334) at com.android.ddmlib.JdwpPacket.writeAndConsume(JdwpPacket.java:213) at com.android.ddmlib.Client.sendAndConsume(Client.java:575) at com.android.ddmlib.HandleHeap.sendREAQ(HandleHeap.java:348) at com.android.ddmlib.Client.requestAllocationStatus(Client.java:421) at com.android.ddmlib.DeviceMonitor.createClient(DeviceMonitor.java:837) at com.android.ddmlib.DeviceMonitor.openClient(DeviceMonitor.java:805) at com.android.ddmlib.DeviceMonitor.processIncomingJdwpData(DeviceMonitor.java:765) at com.android.ddmlib.DeviceMonitor.deviceClientMonitorLoop(DeviceMonitor.java:652) at com.android.ddmlib.DeviceMonitor.access$100(DeviceMonitor.java:44) at com.android.ddmlib.DeviceMonitor$3.run(DeviceMonitor.java:580) 

Спасибо за отличные предложения, ребята! Но я решил проблему. Я переустановил Eclipse, Android SDK, и у меня все еще была проблема. Оказывается, мой debug.keystore истек, и все, что мне нужно было сделать, это удалить этот файл, как описано здесь: ошибка «Debug certificate expired» в плагинах Eclipse Android. Я развиваюсь уже несколько лет, но, по общему признанию, Пара систем перестраивается здесь и там, и только на прошлой неделе мой debug.keystore был старше года. Идите по фигуре ….

Затем, поскольку я переустановил Eclipse, у меня была эта проблема: http://androidcodemonkey.blogspot.com/2011/10/how-to-solve-must-override-superclass.html

Я снова и снова работаю.

Попробуйте Cleaning свой проект.

Автоматическая проверка build .

Restart Eclipse.

Если ничего не работает, выполните backup всех ваших проектов и reinstall Eclipse и SDK. Ничего другого.

Intereting Posts