Intereting Posts
Как открыть другое действие по элементу recyclerView onclick Добавить пользовательский макет на панель инструментов Android: Тип java.awt.Image не может быть разрешен. Это косвенно ссылается на требуемые файлы .class Использование Gradle для разделения внешних библиотек в разделенных файлах dex для решения ограничений метода Dalvik 64k для Android Глобальная переменная Android, не работающая в службе Как сделать липкие заголовки разделов (например, iOS) в Android? Пример Android для AsyncTask Анимация при изменении текста После обновления до google play services 8.4.0 мое приложение падает при запуске Поддерживают ли браузеры iPhone / Android браузер CSS @media? Drawables не будет нажимать на github Android Studio Android: Как сделать все элементы внутри LinearLayout того же размера? Обнаруживать отмену действий пользователя при программной установке apk Android Studio: обнаружен незарегистрированный корень VCS В чем разница между removeAllViews () и removeAllViewsInLayout ()

Как я могу упаковать весь интерпретатор python в Android APK?

Я знаю о SL4A и как я могу запускать скрипты Python в Android.

Мне нужно знать, как я могу упаковать весь интерпретатор Python внутри своего APK, поэтому моим конечным пользователям не придется загружать и устанавливать SL4A перед запуском моего приложения.

Благодарю.

Solutions Collecting From Web of "Как я могу упаковать весь интерпретатор python в Android APK?"

Попробуйте посмотреть на kivy.org .

Это python на графическом интерфейсе Multiitouch на базе Android, в документации объясняется, как создать пакет со всем, чтобы опубликовать его в магазине Android.

Я также помню, что была глава о книге Pro Android Python с SL4A, в которой объяснялось, как упаковать все и публиковать.

Надеюсь это поможет

Существует проект android-python27 , который фактически работает с интерпретаторами, отличными от Python 2.7, несмотря на название. Если вы хотите связать приложение Python с интерпретатором в одном APK, это единственный вариант. Вы можете использовать разные интерпретаторы и добавлять свои собственные библиотеки Python и такие вещи.

Очень грустно использовать, чтобы быть честным. «Удобный для пользователя» подход требует Eclipse ~, но если вы готовы упаковать свое приложение, он выполняет эту работу.

Он доступен под лицензией Apache 2.0.