Ошибка. Причина. Не удалось найти допустимый путь сертификации для запрошенной цели.

Я получил следующую ошибку в android Studio 2.2.3, когда я синхронизирую граду.

Ошибка. Причина. Не удалось найти допустимый путь сертификации для запрошенной цели.

Как я могу исправить эту проблему?

Я добавляю свой файл Gradle также

apply plugin: 'com.android.application' android { compileSdkVersion 25 buildToolsVersion "25.0.2" defaultConfig { applicationId "com.sample.myapplication" minSdkVersion 16 targetSdkVersion 22 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:23.4.0' compile 'com.android.support:design:23.4.0' compile 'com.android.support:palette-v7:23.4.0' testCompile 'junit:junit:4.12' // FireBase compile 'com.google.firebase:firebase-messaging:9.0.0' }//Add this line apply plugin: 'com.google.gms.google-services' 

И проект уровня Gradle File

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.3' classpath 'com.google.gms:google-services:3.0.0' } } allprojects { repositories { mavenCentral() jcenter{ url "http://jcenter.bintray.com/" } maven { url "https://jitpack.io" } } } task clean(type: Delete) { delete rootProject.buildDir } 

Solutions Collecting From Web of "Ошибка. Причина. Не удалось найти допустимый путь сертификации для запрошенной цели."

Я столкнулся с этой проблемой с ранее созданной Maven. Это происходило, потому что я работал в ограниченной офисной сети. Вам необходимо импортировать требуемый сертификат в хранилище ключей.

Следуйте шагам в ответе ниже вопроса «не удалось найти допустимый путь сертификации для запрошенной цели», но браузер говорит, что это нормально

(Используйте двойные кавычки для fienames / pathnames)

Примечание. Я не могу найти точный источник, из которого я решил проблему, если я получу его, я обновлю его

Вы используете более старую версию библиотек.

 compile 'com.android.support:appcompat-v7:25.2.0' compile 'com.android.support:design:25.2.0' compile 'com.android.support:palette-v7:25.2.0' compile 'com.google.firebase:firebase-messaging:10.2.0' 

Эта проблема может быть связана с некоторыми ограниченными интернет-соединениями … Если вы устанавливаете инструменты сборки в какой-либо ограниченной сети, требуемые сертификаты могут не устанавливаться … Поэтому попробуйте изменить сетевое подключение … Работал для меня …. ,

Я пропустил эту проблему после студии обновления и градации, в файле журнала мне сообщается, что у какого-то магазина maven есть проблема с сертификатом.

Я попробовал перезапустить statudio как предложение, но дозировать работу; И кто-то сказал, что мы должны установить среду jre, но я не знаю, как установить ее на Mac. Поэтому я попробовал перезагрузить Mac. И начать студию, я нашел эти советы. Введите описание изображения здесь

Поэтому проблема плавающая на поверхности: решение: первый шаг: перезагрузить компьютер, слишком много проблем после обновления студии Android. Второй шаг: используйте старый инструмент градации ИЛИ загрузите * pom и jar, поставьте правильную папку.