«Неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse» с помощью SDK Tools v22

Недавно я обновил свои Android SDK Tools до версии 22. Но всякий раз, когда я пытаюсь создать новый проект в Eclipse, я получаю сообщение об ошибке:

Неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse

Как я могу исправить эту проблему?

Solutions Collecting From Web of "«Неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse» с помощью SDK Tools v22"

Загрузите с http://dl-ssl.google.com/android/repository/tools_r22-windows.zip , разархивируйте его и замените в папке / tools этим, чтобы понизить инструменты sdk. В версии 22 есть ошибка.

Для Mac http://dl-ssl.google.com/android/repository/tools_r22-macosx.zip

Для Linux: http://dl-ssl.google.com/android/repository/tools_r22-linux.zip

Участник проекта опубликовал комментарий № 55, который решает эту проблему, не загружая инструменты SDK. Просто загрузите шаблоны действий и замените папку sdk/tools/templates/activities содержимым ZIP-файла.

Возможно, вам придется перезапустить Eclipse с помощью параметра -clean для его работы.

От Eclipse откройте «Справка»> «Проверить обновления» и установите любое обновление, которое показывает Eclipse.

После обновления компонентов SDK всегда требуется обновить плагины Eclipse.

Вчера я столкнулся с тем же вопросом, когда обновился до последних Android SDK Tools (22.2). Поэтому я вернул обратно изменения и теперь использую Android SDK Tool (22.0.5), и он отлично работает.

Попробуйте переопределить Android SDK Tools.