Хотите использовать ViewPager, не можете получить android.support. * Быть узнанным?

EDIT Извините за все фотографии. Я попытался дать вам лучшее представление о том, где я нахожусь.

Я пытаюсь заставить ViewPager работать над моим приложением, но он не узнает Support Library которую я загрузил в диспетчере SDK.

Я кодирую SDK версии 10. Это снимок экрана моего SDK Manager :

Введите описание изображения здесь

После установки Android Support Library и последних Tools я пошел в Help >> Check for Updates . После запуска я получаю два всплывающих окна, показанных ниже.

Введите описание изображения здесь

В Problem Occured появляется сообщение о том, что он не может найти репозиторий на этом сайте. Я установил Sequoyah Natice Code Support когда я впервые начал разрабатывать это приложение, но никогда не использовал его. Я попытался переустановить пакет, чтобы избавиться от этого всплывающего окна, но он не позволит мне, поскольку он уже установлен.

Введите описание изображения здесьВведите описание изображения здесь

В моем коде я получаю сообщение об ошибке при попытке import android.support.v4.view.ViewPager; , Снимок экрана ниже. Когда я наводил курсор на строку import , он говорит, что The import android.support.v4 cannot be resolved.

Введите описание изображения здесь

Чтобы добавить библиотеку поддержки Android в существующий проект Android:

  • Щелкните правой кнопкой мыши на своем проекте
  • Нажмите Android Tools
  • Нажмите Add Support Library

Это должно позаботиться о создании android-support чтобы он мог использоваться проектом.

Для Android Studio 1.2.2

  • Щелкните правой кнопкой мыши на своем проекте из иерархии файлов (скажем, «приложение»)
  • Выберите «Открыть настройки модуля» в меню
  • Перейдите на вкладку «Зависимости»
  • Нажмите кнопку «плюс» внизу
  • Выберите «Библиотека зависимости»
  • Поиск / Выбор нужной библиотеки поддержки
  • Нажмите ОК.