Поддерживает ли Robolectric уровень API-интерфейса?

У меня есть тест, который я бы хотел запустить с Robolectric, я использую 2.3-SNAPSHOT, поскольку мой APP использует ActionbarCompat, который мне нужен для использования версии 2.3-SNAPSHOT, поскольку Robolectric ранее не мог найти темы AppCompat. Поэтому я настраиваю Classpath в Eclipse, и в итоге я получаю следующее:

java.lang.UnsupportedOperationException: Robolectric does not support API level 9, sorry! at org.robolectric.SdkConfig.<init>(SdkConfig.java:24) at org.robolectric.RobolectricTestRunner.pickSdkVersion(RobolectricTestRunner.java:288) at org.robolectric.RobolectricTestRunner.getEnvironment(RobolectricTestRunner.java:264) at org.robolectric.RobolectricTestRunner.access$100(RobolectricTestRunner.java:57) at org.robolectric.RobolectricTestRunner$2.evaluate(RobolectricTestRunner.java:186) at org.junit.runners.BlockJUnit4ClassRunner.runNotIgnored(BlockJUnit4ClassRunner.java:79) at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:71) at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:49) at org.junit.runners.ParentRunner$3.run(ParentRunner.java:193) at org.junit.runners.ParentRunner$1.schedule(ParentRunner.java:52) at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:191) at org.junit.runners.ParentRunner.access$000(ParentRunner.java:42) at org.junit.runners.ParentRunner$2.evaluate(ParentRunner.java:184) at org.robolectric.RobolectricTestRunner$1.evaluate(RobolectricTestRunner.java:172) at org.junit.runners.ParentRunner.run(ParentRunner.java:236) at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:50) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197) 

Манифест моего тестового проекта выглядит следующим образом:

 <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.vendor.test" android:versionCode="1" android:versionName="1.0"> <application> <uses-library android:name="android.test.runner" /> </application> <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="19" /> <instrumentation android:name="android.test.InstrumentationTestRunner" android:targetPackage="com.vendor" /> </manifest> ? <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.vendor.test" android:versionCode="1" android:versionName="1.0"> <application> <uses-library android:name="android.test.runner" /> </application> <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="19" /> <instrumentation android:name="android.test.InstrumentationTestRunner" android:targetPackage="com.vendor" /> </manifest> 

Я всегда жалуюсь на уровень API, независимо от того, что я использую.

Кто-нибудь получил эту работу?

Обновление: аннотация теперь @Config(sdk = 18) (или @Config(sdk = Build.VERSION_CODES.JELLY_BEAN_MR2) ), а файл свойств, упомянутый в ссылке, теперь robolectric.properties .

Исходный ответ: вы можете использовать аннотацию @Config чтобы Robolectric эмулировал версию SDK. Вы можете поместить это:

 import org.robolectric.annotation.Config; @Config(emulateSdk = 18) // now @Config(sdk = 18) as of Robolectric 3.0 @RunWith(RobolectricTestRunner.class) public class SomeTest ... 

Это также возможно с использованием файла, указанного здесь

Не уверен, что это означает для ваших конкретных тестов KitKat, но по крайней мере другие должны работать.

В случае, если такие люди, как я, все еще посещая ссылку на аналогичную ошибку,

@Config(emulateSdk = ) теперь не работает. Его изменение на sdk–
@Config(constants = BuildConfig.class, sdk=21)

Для меня я получал ошибку с целевой версией 22,

 java.lang.UnsupportedOperationException: Robolectric does not support API level 22 

И поэтому я подражал ему до 21.

Согласно SdkConfig.java , Roboelectric поддерживает только следующие версии / уровни API:

 SUPPORTED_APIS.put(Build.VERSION_CODES.JELLY_BEAN, new SdkVersion("4.1.2_r1", "0")); SUPPORTED_APIS.put(Build.VERSION_CODES.JELLY_BEAN_MR1, new SdkVersion("4.2.2_r1.2", "0")); SUPPORTED_APIS.put(Build.VERSION_CODES.JELLY_BEAN_MR2, new SdkVersion("4.3_r2", "0")); SUPPORTED_APIS.put(Build.VERSION_CODES.KITKAT, new SdkVersion("4.4_r1", "0")); SUPPORTED_APIS.put(Build.VERSION_CODES.LOLLIPOP, new SdkVersion("5.0.0_r2", "0")); 

Вы уверены, что попробовали?

Это старый вопрос, я добавлю свои 2 цента. Проблема в том, что сам SDK не установлен на вашем компьютере, загрузите правильный SDK из менеджера SDK, и все хорошо.