Qt5.1-android: версия Qt для mips, отсутствующих в QtCreator

Я установил Qt-5.1.0-rc1-android в linux и добавил все доступные версии Qt на вкладке Build & Run в QtCreator (это android_armv7 , android_x86 и gcc_64 ).

Но Творец продолжает говорить мне, что Qt version for architecture mips is missing, to add the Qt version, select Options > Build & Run > Qt Versions. ,

Есть ли какая-то зависимость, о которой я не знаю?

Предпочитайте настройку Android NDK в категории настроек Android, после чего необходимые наборы будут добавляться автоматически. Но я не уверен, что Qt 5.1.0 для Android также содержит изображения мип. Если это не так, вы должны вручную создать Qt для mips.

Из-за отсутствия поддержки MIPS в движке JavaScript, используемом в QtQuick 2, для этой архитектуры нет двоичного пакета.

Если ваше приложение не требует Qt Quick 2, вы можете вручную создать Qt для MIPS. Если вам требуется Qt Quick 2 для MIPS, к сожалению, единственным решением в настоящее время является создание из репозитория dev (который находится в активной разработке, а не стабильный) или ждет Qt 5.2, где эта проблема должна быть исправлена.

Если ваше приложение не требует поддержки MIPS, вы можете смело игнорировать предупреждение в Qt Creator.