Intereting Posts
ImageView adjustViewBounds не работает Правильный способ проверки всех флажков в ListView? Исходное значение 1.5 устарело и будет удалено в будущей версии Дополнительное текстовое пограничное выражение для Android Мне нужны как Robolectric, так и Mockito в моем тесте, каждый из них предлагает свой собственный TestRunner Режим «Дозировка» и «Передний план» Некоторые из глификонов Bootstrap3 отображаются неправильно на веб-сайте phonegap android webview Кэширование наложений путем округления прямоугольников координат – как? Создайте версию apk с настройкой формата имени в Android Studio Как получить электронную почту пользователя на GraphRequest.newMeRequest Как выполнить SQLite-запрос в приложении Android? Проверка подписи на покупку приложения с помощью PHP openssl Как обновить схему таблицы после обновления приложения на Android? Branch.io deeplink в android открывает Play Store даже независимо от того, что Eclipse import google-play-services_lib отображает ошибку в значениях

Pro Guard ошибка сборки релиз apk

Я получаю следующую ошибку, пытающуюся создать версию apk

:app:compileReleaseNdk UP-TO-DATE :app:compileReleaseSources :app:lintVitalRelease :app:proguardRelease Warning: android.support.v4.app.NotificationCompat$NotificationCompatImplBase: can't find referenced method 'void setLatestEventInfo(android.content.Context,java.lang.CharSequence,java.lang.CharSequence,android.app.PendingIntent)' in library class android.app.Notification Warning: android.support.v4.app.NotificationCompat$NotificationCompatImplGingerbread: can't find referenced method 'void setLatestEventInfo(android.content.Context,java.lang.CharSequence,java.lang.CharSequence,android.app.PendingIntent)' in library class android.app.Notification Warning: android.support.v4.app.NotificationCompatGingerbread: can't find referenced method 'void setLatestEventInfo(android.content.Context,java.lang.CharSequence,java.lang.CharSequence,android.app.PendingIntent)' in library class android.app.Notification Warning: there were 3 unresolved references to library class members. You probably need to update the library versions. (http://proguard.sourceforge.net/manual/troubleshooting.html#unresolvedlibraryclassmember) :app:proguardRelease FAILED 

В build.gradle у меня есть следующее:

Dependties {compile "com.android.support:support-v4:23.0.0"}

И все равно получите ту же ошибку, если я изменю ее на "com.android.support:support-v13:23.0.0"

Когда в сообщении об ошибке говорится следующее: «Возможно, вам необходимо обновить версии библиотеки». В какой библиотеке это относится и как ее обновить?

В документации, упомянутой в этой ошибке, говорится: "If you're developing for Android and ProGuard complains that it can't find a method that is only available in a recent version of the Android run-time, you should change the build target in your project.properties file or build.gradle file to that recent version. You can still specify a different minSdkVersion and a different targetSdkVersion in your AndroidManifest.xml file."

Вот мой build.gradle, который является самым последним, поскольку есть его API 23. Так как я могу исправить проблему?

 android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.cequint.ecid" minSdkVersion 23 compileSdkVersion 23 } 

Solutions Collecting From Web of "Pro Guard ошибка сборки релиз apk"