Intereting Posts
Есть ли способ освободить камеру от различной активности после ее приобретения из другого вида деятельности? Установка Visual Studio 2015 зависает в Android SDK Setup (API-уровень 19 и 21) и уровень 22 Android: мягкая клавиатура выдвигает весь макет, необходимо изменить размер списка Как изменить цвет фона терминала Android Studio Как декодировать URL в приложении Android Как поместить изображение справа от переключателя, Android Facebook LoginButton для Android не принимает значения login_text и logout_text, переданные из XML Можно ли предлагать маршруты с Google Maps в приложении android2.2? Предварительная загрузка в режиме скольжения не сохраняется в кеше Использование тегов фрагментов Android 4.4.2 – камера uri возвращает значение null, а также функция обрезки не работает? Как получить покрытие кода с помощью Android Studio? Не удалось найти свойство processManifest на com.android.build.gradle.internal.api.ApplicationVariantImpl Как исключить модуль из всех зависимостей, но оставить явное объявление Gradle Получить местоположение изображения – Телефонная камера

Образец native-audio в проблеме сборки NDK

У меня возникла проблема при создании примера native-audio в NDK. Основная причина: «SLES / OpenSLES.h: нет такого файла или каталога»

У меня есть googled, но я не нахожу ничего полезного.

Пожалуйста, помогите мне.

заранее спасибо

Solutions Collecting From Web of "Образец native-audio в проблеме сборки NDK"

Если вы строите из командной строки, попробуйте

Ndk-build TARGET_PLATFORM = андроид-9

Это связано с вашей версией Android. Указать версию Android при сборке.

Ndk-build TARGET_PLATFORM = андроид-9

У меня также есть эта проблема, но теперь она работает. Вы должны использовать именно API Android 9. В Eclipse создайте новый проект из существующего источника (образец native-audio), целью которого является Android 2.3.1, а затем создайте общую библиотеку с помощью ndk-build. Наконец, создайте свой проект в Ecclipse обычным способом. Надеюсь, это поможет вам.

Если вы используете Android Studio и файл Application.mk . Установите версию платформы Android с помощью:

 //replace 'x' with the platform version you are targeting APP_PLATFORM := android-x 

Нажмите здесь для ссылки ndk-r10c. Я использую ndk-r10e, и он по-прежнему использует одну и ту же переменную.

В Android Studio вы можете решить эту проблему, добавив следующую строку в файл project.properties :

 target=android-23 // replace 23 with the api you are targeting 

Файл project.properties должен находиться внутри основного каталога, если его нет, вы можете создать файл, и он должен работать нормально.