MapActivity не может быть разрешен для типа, даже с целью Google API

Я также получаю «импорт com.google не может быть разрешен для типа», и я не уверен, что это связано, но мой проект отлично работает на Android 2.3.3, но зависает при запуске в Google API 2.3.3 и 4,0,

Ps я включил

<uses-library android:name="com.google.android.maps" /> 

Пожалуйста помоги! благодаря

Во время компиляции вам нужно указать правильную библиотеку. Но то, что вы описываете, требует от Android использовать эту конкретную библиотеку во время выполнения.

Вам нужно щелкнуть правой кнопкой мыши проект Eclipse, Свойства -> Android. В Project Build Target выберите любую цель у поставщика Google Inc. ..

Проблема в том, что вы не используете Google Api для конкретной платформы Android. Простое подгонка подходящего целевого API Google решит проблему.

Введите описание изображения здесь

Intereting Posts