Компоненты архитектуры Kotlin kapt и android

Я использую компоненты Kotlin, kapt и Android Architecture. Когда я строю проект, все кажется прекрасным, но после попытки запустить приложение на устройстве / эмуляторе Gradle's: собрать задачу выкинуть эти ошибки:

Предупреждение: предупреждение: поддерживаемая исходная версия 'RELEASE_7' из обработчика аннотаций 'android.arch.persistence.room.RoomProcessor' меньше, чем -source '1.8'

Предупреждение: предупреждение: Поддерживаемая исходная версия 'RELEASE_7' из обработчика аннотаций 'android.arch.lifecycle.LifecycleProcessor' меньше, чем -source '1.8'

Предупреждение: предупреждение: Следующие параметры не были распознаны каким-либо процессором: '[kapt.kotlin.generated]'

И сборка не удалась. Может кто-нибудь мне помочь?

ОБНОВИТЬ

  • Модуль build.gradle ЗДЕСЬ
  • Проект build.gradle ЗДЕСЬ

У меня была та же проблема с версией 1.0.0-alpha3, но с версией 1.0.0-alpha1 все работает нормально.

Intereting Posts
Подключение к защищенной паролем Wi-Fi сети с помощью оболочки adb В чем причина ошибки «Устройство поддерживает x86, но APK поддерживает только armeabi-v7a» Почему собственный поток oauth2 для Google требует секретности клиента? Настройка C ++ 11 (std :: thread) для NDK с помощью ADT / Eclipse Java.lang.IllegalStateException: эта функция доступна только для экземпляров бэкэнд Сбой приложения Android при вызове MediaController.show () – Невозможно добавить окно – токен null недействителен Отборочные макеты Galaxy Tab 10 Как написать простой видеоплеер на Android? Тип байта странный Сохранить несколько изображений на Android Почему этот образ обработки изображений Google Renderscript работает медленнее на графическом процессоре в Nexus 5 Как избежать дублирования объектов в базе данных DB4o Уведомления не всегда принимаются по телефону? Android WebView: большое местное изображение не загружено / показано Царство: как запросить много-много полей