Не удается найти файл класса для java.lang.Object

Я заново затенил свое затмение. А затем импортировал все проекты в Eclipse, но каждый проект имеет общую ошибку:

Cannot find the class file for java.lang.Object. at Line 1.

Я проверил свой Java-путь. Но не в состоянии разобраться.

Проверьте это, если он работает:

Проблема с вашими репозиториями java. Я полагаю..:

Goto Help > Install New Software > Нажмите кнопку « Add .

По всплывающему окну:

Имя: ADT

Местоположение: https://dl-ssl.google.com/android/eclipse

Установите все доступные программные средства в списке. Это может сработать.

Хорошего дня!!!

Щелкните правой кнопкой мыши Project -> Properties, Java Build Path.

Введите описание изображения здесь

Проверьте, установлена ​​ли JRE. Если установлено, нажмите «EDIT» и проверьте, указывает ли его правильное местоположение

Введите описание изображения здесь

Более быстрый путь будет

Щелкните правой кнопкой мыши Project —> Свойства —> Путь сборки —> Добавить внешние банки -> Найдите ваш android-xx.Jar, например, android-17.jar

В моем случае я использую adt, и он здесь

E: \ ADT-пачка окно-x86_64-20130219 \ вст-пачка окно-x86_64-20130219 \ SDK \ платформа \ андроид-17

Надеюсь, поможет

Это случилось со мной, когда я попытался объединить две ветви проекта Android, используя eGit. По какой-то причине мой путь сборки в основном исчез (возможно, один из файлов был не проверен).

Чтобы вернуть JRE и андроидные библиотеки, я просто щелкнул правой кнопкой мыши по проекту в проводнике проекта и нажал Android Tools -> Fix Project Properties (эти параметры доступны только в том случае, если у вас установлен Android ADT).

Попробуй это:

Перейти к Build Path -> Libraries -> Add Library -> JRE System Library -> Select JRE

Я не уверен, но вы можете пропустить JRE System Library в своем проекте, это происходит не часто, но это возможно.

У меня просто была эта проблема, и все, что мне нужно было сделать, это очистить всю рабочую область, то есть все проекты в рабочей области. Ошибка исчезла.

У меня возникла эта проблема после установки более новой версии Google ADT. Решение, по крайней мере работающее с ОС X, состоит в том, чтобы сделать копию вашего проекта в безопасном месте, полностью удалить его из Eclipse и затем снова импортировать с помощью File-> Import-> General-> Existing Projects в Workspace.

FYI

Я использую Google для OS X Mavericks для разработчиков Android. Build: v22.2.1-833290

Но я почти уверен, что делал это в прошлом с предыдущими версиями OSX и ADT.

У меня тоже была эта проблема, и в моем случае проблема заключалась в том, что в файле .classpath текущего проекта отсутствовала следующая строка:

<classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>

Добавление его решило проблему для меня.

Эта ошибка объясняется тем, что одна из «частных библиотек Android» либо повреждена, либо неправильной версии. В моем случае это была поддержка android-v4.jar . Я заменил его одним из рабочего проекта, и он работает.

Intereting Posts