Import android не может быть разрешен

Я открыл проект, который я не открывал через некоторое время в Eclipse. Я не смог скомпилировать из-за некоторых (необъяснимых) ошибок.

import android.app.Activity; import android.os.Bundle; import android.view.animation.AnimationUtils; import android.widget.ImageView; import android.view.animation.Animation; import android.content.Intent; 

Выдает следующую ошибку:

Import android не может быть разрешен

Что я могу сделать для решения этой проблемы?

Solutions Collecting From Web of "Import android не может быть разрешен"

Сначала попробуйте очистить / построить свой проект.

Если проблема не устранена. Щелкните правой кнопкой мыши по проекту -> перейти к свойствам -> перейти к андроиду -> выбрать версию для Android, и это должно сработать.

Надеюсь, поможет.

Попробуйте один из них:

  • «Очистить» проект Eclipse: перейдите в Project> Clean in Eclipse [Это, похоже, работает для меня]

  • Обновите свою папку проекта (щелкните правой кнопкой мыши по проекту> обновить). Восстановите свой проект

  • Очистите свои сборки (при использовании Ant или Maven – очистите свои сборки). Создайте новый проект в Eclipse.

  • «Переключить» Workspace – затем переключиться обратно (например, «Изменить на Debug», затем переключиться обратно на Java)

  • «Переключить» Workspace – затем переключиться обратно (например, «Изменить на Debug», затем переключиться обратно на Java)

  • Удалите и снова добавьте JRE:

    1. Щелкните правой кнопкой мыши на своем проекте> свойства
    2. Перейдите на вкладку «Библиотеки»
    3. Нажмите на JRE
    4. Нажмите «Удалить», затем «ОК».
    5. Повторите 1-3 раз, но снова добавьте JRE

Ну, я также столкнулся с этой проблемой, когда импортировал существующий проект Android из друга в мое рабочее пространство. Я обнаружил, что мне не хватает библиотеки JRE, но также и библиотеки Android (Android Classpath Container library). Вы можете добавить его так:

  1. Щелкните правой кнопкой мыши на своем проекте> свойства
  2. Перейдите на вкладку «Библиотеки»
  3. Нажмите кнопку «Добавить библиотеку ..» справа
  4. Добавить библиотеку контейнеров класса Android

Удачи!

Также убедитесь, что текущее приложение и импортированные библиотеки / приложения имеют одинаковые версии API для Android … (14, 15, 17 и т. Д.) … Несоответствие версии API также вызовет ту же проблему.

Это обновленный ответ, если вы используете Android Studio. Вы можете столкнуться с этой проблемой из-за того, как она кэшируется.

В случае, если вы получите эту ошибку с любым пакетом, вам стоит пойти в File -> Invalidate Cache / Restart и выбрать, чтобы удалить кеш.

Это также может устранить проблемы, которые иногда могут сохраняться между переустановками из-за того, что при удалении Android Studio не удаляет кеш.

В моем случае мне нужно перейти в «Свойства»> «Путь сборки Java»> «Заказ и экспорт»

После проверки библиотеки Android 4.0 (может быть другая версия в вашем случае) она начала работать

Поэтому ни один из других решений не работал для меня, но я нашел другой способ, который работал для меня.

Щелкните правой кнопкой мыши по проекту -> перейти к свойствам -> Путь сборки Java -> Библиотеки -> Добавить внешние JARs

YOUR_DRIVE \ Android-SDKs \ платформы \ android- ??

Добавить файл android.jar