Intereting Posts
Метод активности вызова от широковещательного приемника Пример проекта для выбора нескольких контактов Специальные символы заменяются квадратом в приложении для Android Пользовательские схемы URI для Facebook Messenger База данных SQLite в android и java Устройство «unknown-sdk» при выполнении тестов в Jenkins Библиотека Android AAR в зависимости от другой библиотеки Как закрыть все действия моего приложения? Эмулятор Android Studio не работает в течение нескольких часов Как сделать LinearLayout прокручиваемым без использования Scrollview Наложение или скрыть панель инструментов при выборе копии / выреза SetBackgroundResource действует отличным от setBackground с помощью RippleDrawable Zoom textview с изображением и текстом (содержание Html) в android Какова позиция адаптера RecyclerView, связанная с индексом его набора данных? Добавить несколько ярлыков запуска приложений в меню приложений во время выполнения

Как установить gradle-3.0 вручную

Я пытаюсь настроить новый gradel-3.0, но я получаю ошибку, как это

Error:Cause:org.gradle.api.internal.tasks.DefaultTaskInputs$TaskInputUnionFileCollection cannot be cast to org.gradle.api.internal.file.collections.DefaultConfigurableFileCollection 

Возможные причины этой непредвиденной ошибки:

  • Кэш зависимостей Gradle может быть поврежден (это иногда происходит после таймаута сетевого соединения.) Заново загружать зависимости и проект синхронизации (требуется сеть)
  • Состояние процесса сборки Gradle (демона) может быть повреждено. Остановка всех демонов Gradle может решить эту проблему. Стоп Gradle строить процессы (требуется перезагрузка)
  • В вашем проекте может быть сторонний плагин, который несовместим с другими плагинами проекта или версией Gradle, запрошенной проектом.

В случае коррумпированных процессов Gradle вы также можете попытаться закрыть среду IDE, а затем убить все процессы Java.

Я пробовал весь метод, приведенный здесь , я снова перезапустил свой ноутбук, но затем также получаю ту же ошибку. Как исправить это, любой подсказка будет полезна.

Обновите инструменты построения градиента, чтобы:

classpath 'com.android.tools.build:gradle:2.2.0-beta1'