Не удалось синхронизировать Gradle: не удалось обновить плагин Android до версии 2.0.0,

Недавно я обновил Android Studio до версии 2.0. Я работаю на частичном курсе, и мне нужно работать над проектом. Когда gradle попытался построить проект, появилось диалоговое окно с просьбой обновить плагин-градиент студии Android. Когда я нажал обновление, я получил ошибку, которая находится в заголовке.

Мои файлы градиента:

Грейд-обертка:

#Wed Sep 30 11:56:02 PDT 2015 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-2.2-bin.zip 

Модуль Gradle:

 apply plugin: 'com.android.application' apply plugin: 'android-apt' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.example.sam_chordas.stockhawk" minSdkVersion 15 targetSdkVersion 23 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } repositories { maven { url "https://jitpack.io" } } dependencies { compile 'com.google.android.gms:play-services-gcm:8.4.0' compile 'com.squareup.okhttp:okhttp:2.5.0' apt 'net.simonvt.schematic:schematic-compiler:0.6.3' compile 'net.simonvt.schematic:schematic:0.6.3' compile 'com.melnykov:floatingactionbutton:1.2.0' compile 'com.android.support:design:23.1.1' compile('com.github.afollestad.material-dialogs:core:0.8.5.7@aar') { transitive = true } } 

Project Gradle:

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() mavenCentral() } dependencies { classpath 'com.neenbedankt.gradle.plugins:android-apt:1.2' classpath 'com.google.gms:google-services:1.4.0-beta3' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

Я не могу работать над проектом, поскольку я не могу его построить. Если у кого-то были какие-то проблемы, и это исправлено, я бы очень признателен за помощь, так как я трачу много времени. Я должен упомянуть, что это машина Windows 7.

благодаря

1) Поскольку вы используете compileSdkVersion = 23 , вам нужно использовать библиотеки поддержки версии, начиная с 23. Это ваш com.android.support:design:23.3.0 в вашем случае. Он может быть не связан с проблемой, но позже он сохранит ваши ошибки во время выполнения, поэтому исправьте ее как можно скорее.

2) Распределение градиента слишком велико для плагина для Android. Используйте это в gradle/gradle-wrapper.properties :

 distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip 

3) Новые инструменты сборки – "23.0.2" . Обновите значение в файлах build.gradle ваших модулей.

4) Плагин сервисов Google Play должен быть такой же, как плагин Android build. По крайней мере, это должно было быть на бета-этапах, и я предполагаю, что главная версия должна соответствовать в любом случае. Это в вашем проекте build.gradle :

 classpath 'com.google.gms:google-services:2.0.0' 

5) Пока на нем отсутствует плагин для Android-сборки !

 classpath 'com.android.tools.build:gradle:2.0.0' 

Необязательный

6) Ваш плагин apt устарел. Самая новая версия – 1.8.

 classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8' 

7) Ваша библиотека OkHttp устарела. Самые новые версии – 2.7.5 или 3.2.0.

 compile 'com.squareup.okhttp:okhttp:2.7.5'