Ошибка устаревших сервисов Google Play

У меня проблема с сервисом google-play. Я использую API-интерфейс Google для аутентификации oAuth2 и Calendar / Gmail. Вчера все работало нормально, но сегодня он говорит мне, что мне нужна новая версия Службы Google PLAY. Сегодня утром Android Studio обновила все пакеты. Вот строка ошибок из Logcat, если я начну обращаться к GoogleAPI:

09-22 11:59:01.692: W/GooglePlayServicesUtil(2819): Google Play services out of date. Requires 9683000 but found 9452480 

Вот мой класс.build:

 apply plugin: 'com.android.application' android { signingConfigs { config { keyAlias XXXXX keyPassword XXXX storeFile file(XXXX) storePassword XXXXX } } compileSdkVersion 23 buildToolsVersion '22.0.1' defaultConfig { applicationId XXXX minSdkVersion 14 targetSdkVersion 22 signingConfig signingConfigs.config vectorDrawables.useSupportLibrary = true } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' signingConfig signingConfigs.config } debug { debuggable false jniDebuggable false signingConfig signingConfigs.config renderscriptDebuggable false } } productFlavors { } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile('com.google.api-client:google-api-client-android:1.22.0') { exclude group: 'org.apache.httpcomponents' } compile('com.google.apis:google-api-services-gmail:v1-rev48-1.22.0') { exclude group: 'org.apache.httpcomponents' } compile('com.google.apis:google-api-services-calendar:v3-rev212-1.22.0') { exclude group: 'org.apache.httpcomponents' } compile 'com.android.support:appcompat-v7:23.2.1' compile 'com.google.firebase:firebase-crash:9.6.0' compile 'joda-time:joda-time:2.4' compile 'com.google.android.gms:play-services-auth:9.6.0' compile 'pub.devrel:easypermissions:0.1.5' compile 'com.android.support:support-v4:23.4.0' compile 'com.android.support:support-vector-drawable:23.4.0' } apply plugin: 'com.google.gms.google-services' 

Я всегда использую com.google.android.gms: play-services-auth Version 9.6.0. Я не понимаю, где я могу изменить версию.

Я попытался поднять свой номер версии, и он дает мне 213XXXX:

 int test = R.integer.google_play_services_version; String test2 = test+""; Toast.makeText(this,test2, Toast.LENGTH_SHORT).show(); 

Но в сообщениях об ошибках отображаются разные номера версий:

 09-22 13:28:26.145: W/GooglePlayServicesUtil(3334): Google Play services out of date. Requires 9683000 but found 9452480 

Большое спасибо, j. Доу;)

Я думаю, что есть открытая проблема с ошибкой, которую вы получили « Службы Google Play устарели на API 23 ». Также этот вопрос выходил в 2013 году, когда вы обновляете свой SDK до 18. Просто проверьте ссылку на эту проблему на Узнайте больше об этом.

Что я могу предложить вам, обновите свою зависимость от последней версии. После его обновления создайте новое виртуальное устройство / эмулятор при тестировании приложения. Попробуйте использовать версию API 23 для x86-64.