Устройства Genymotion, не работающие в Eclipse на OS X Yosemite

Я обновил от Mavericks до Yosemite, и теперь я больше не могу использовать какое-либо устройство Genymotion.
Вы можете видеть устройства в Eclipse, но если вы хотите запускать приложение, вы не можете выбрать одно из этих устройств.

Я уже переустановил Eclipse, Genymotion и Virtualbox …

Диспетчер виртуальных устройств Genymotion показывает Nexus 5, в котором указано «Вкл.», Диспетчер виртуальных устройств Genymotion показывает Nexus 5, а stat - «On»

Когда я хочу запустить приложение, нет Nexus 5 .. Android-устройство Chooser не показывает Nexus 5

Это ошибка в eclipse – OSX yosemite, что вам нужно сделать в окне выбора устройства Android, попробуйте ИЗМЕНИТЬ ТАБЛИЦУ СЕРИЙНОГО НОМЕРА, и вы увидите, что запущен эмулятор genymotion

Если вы этого не видите или окно выбора устройства Android не появляется, перед повторным запуском проверьте три вещи:

  1. Параметры разработчика включены из настроек (путем повторного касания 7-кратного номера сборки в телефоне), хотя параметры разработчика доступны в списке приложений в эмуляторе genymotion
  2. В разделе «Настройки»> «Безопасность» включите «Неизвестные источники»
  3. Откройте «Запустить конфигурацию» (для Android-приложения), выберите вкладку «Цель», «Включить всегда», чтобы выбрать устройство и нажать «Применить».

Кроме того, я загрузил файлы jar с страницы загрузки Genymotion вручную и заменил ее в папке плагина eclipse.

РЕДАКТИРОВАТЬ

FYI, ошибка ошибки AOSP была обнаружена.

Проблема 78436: [ADT / Eclipse] Не удается увидеть мое устройство в диалоговом окне «Выбор устройства Android», даже если оно есть в представлении «Устройства»

Внизу этой страницы есть ссылка на «Голосовать за эту проблему»

Я могу решить эту проблему, подключив реальное устройство один раз.

Прокрутите вниз и посмотрите список устройств, подключенных к ADB. Введите описание изображения здесь

Введите описание изображения здесь

У меня была аналогичная проблема, но моя проблема заключалась в том, что эмулированное устройство работало под управлением Android 4.3 (SDK версии 18), но в приложении был android:minSdkVersion="19" так как ни одно совместимое устройство не было найдено, список был пуст.

Дважды проверьте версию вашего эмулируемого устройства и номер minSdkVersion , чтобы убедиться, что он совместим.