FragmentPagerAdapter не может быть разрешен для типа

Я пытаюсь следовать руководству Google по внедрению ViewPager с помощью фрагментов, используя пакет совместимости, как описано здесь: http://android-developers.blogspot.com/2011/08/horizontal-view-swiping-with-viewpager.html

Я добавил пакет совместимости, и я могу создавать классы, которые расширяют фрагмент и добавлять ViewPager в мой XML-макет, но когда я пытаюсь создать класс адаптера, который расширяет FragmentPagerAdapter, Eclipse, похоже, не знает, что это такое. Что мне не хватает?

Используйте следующие инструкции на этой странице: http://developer.android.com/training/basics/fragments/support-lib.html , просто добавьте библиотеку android-support-v4.jar. Извините за мой английский, я изучаю недавно

Поэтому я исправил эту проблему, загрузив библиотеку совместимости на другом компьютере, подключенном к другой сети (так же, как и раньше, через меню правой кнопки мыши в Eclipse), а затем скопировав полученную поддержку android-support-v4.jar обратно в Оригинальный компьютер.

Новый файл был около 137k по сравнению с версией 104k, которую получала моя локальная версия Eclipse. Я не уверен, откуда возникает несоответствие, но, насколько я понимаю, мой заблокированный корпоративный интернет-доступ блокировал выбор файлов из библиотеки и оставил меня с неполной версией.