Как добавить плагин facebook в кордову с помощью cli

Я использую cordova 3.3.0 cli.I нашел документацию для ручной установки, которая предназначена для проекта eclipse / xcode. Существует также документация для сборки phonegap, которую мы делаем в config.xml. Я просто хочу установить плагин Facebook в свой проект cordova, который я создаю через CLI cordova

Обновление : я пришел из проблемы. Спасибо Кл за его помощь. Я написал полный учебник для этого. Мой учебник для плагина facebook

Solutions Collecting From Web of "Как добавить плагин facebook в кордову с помощью cli"

На самом деле, в CLI вам просто нужно добавить переменные APP_ID и APP_NAME в вашу команду. Что-то вроде этого:

 C:\myProject>cordova plugin add https://github.com/phonegap/phonegap-facebook-plugin --variable APP_ID=your_facebook_app_id --variable APP_NAME=your_facebook_app_name 

Я установил его таким образом, но не уверен, что приложение функционирует или нет. Что-то испытать.

Обновить:

У меня возникла проблема с сборкой phonegap, дающим мне ошибку. One of your plugins requires a parameter: APP_ID, APP_NAME . Это произошло потому, что я не добавлял эти переменные в файл config.xml.

Это разрешило это

 <gap:plugin name="com.phonegap.plugins.facebookconnect"> <param name="APP_ID" value="your_facebook_app_id" /> <param name="APP_NAME" value="your_facebook_app_name" /> </gap:plugin>` 

Теперь все работает отлично! Надеюсь, это поможет кому-то.

Обновление 2:

Не забудьте изменить файл plugin.xml под root / plugins / com.phonegap.plugins.facebookconnect / plugin.xml

 <preference name="APP_ID" /> <preference name="APP_NAME" /> 

Может быть, это поможет, если вы уточните, какой плагин точно вы пытаетесь установить …

Если это плагин для подключения facebook, вы можете попробовать установить его таким образом:

 cd yourprojectname cordova plugin add https://github.com/phonegap/phonegap-facebook-plugin 

Но кажется, что он еще не работает, и вам придется выполнить ручную установку 🙁

Цитата из readme.md:

Этот плагин основан на плагине. Чтобы установить его в приложение, просто выполните plugman следующим образом; В настоящее время он не работает с плагином. РАБОТА В ПРОЦЕССЕ

Поэтому я думаю, вам придется подождать еще немного, чтобы установить его с помощью CLI …