Как исправить eror app \ build \ intermediates \ res \ merged \ debug \ values-v24 \ values-v24.xml

Я получаю сообщение об ошибке при создании проекта.

Ошибка:

Error:Execution failed for task ':app:processDebugResources'. > com.android.ide.common.process.ProcessException: Failed to execute aapt C:\Users\MR Maleki\Desktop\WhoIsBetter2\app\build\intermediates\res\merged\debug\values-v24\values-v24.xml Error:(4) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Colored'. Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Borderless.Colored'. Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Borderless.Colored'. Error:(4) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Colored'. 

Gradle:

  compileSdkVersion GLOBAL_COMPILE_SDK as int buildToolsVersion GLOBAL_BUILD_TOOLS compile fileTree(include: ['*.jar'], dir: 'libs') //----------------- Android Support Library -------------------------------- compile "com.android.support:appcompat-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:design:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:gridlayout-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:cardview-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" 

Как исправить эту ошибку? Что вы посоветуете решить проблему?

Обычно это происходит, когда основная версия вашей библиотеки поддержки не соответствует вашей компиляционной версии SDK.

Например, если вы компилируете SDK версии 24, вы должны использовать версию 24.xx библиотеки поддержки (и наоборот).

См. Также: Ошибка получения родительского элемента: не найден ресурс, который соответствует указанному имени после обновления до AppCompat v23