Intereting Posts

Ошибка запуска Eclipse при попытке запустить приложение для Android

Я пытаюсь настроить свою рабочую станцию ​​для разработки Android с помощью Eclipse Galileo. Я установил последний плагин ADT и Android SDK, но я получаю эту ошибку, когда я пытаюсь запустить любой базовый проект Android, который я создаю.

eclipse.buildId=M20090917-0800 java.version=1.6.0_17 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US Framework arguments: -product org.eclipse.epp.package.java.product -product org.eclipse.epp.package.java.product Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.java.product -data C:\Documents and Settings\dmcnamar\workspace -product org.eclipse.epp.package.java.product Error Tue Jan 26 18:00:41 EST 2010 An internal error occurred during: "Launching HelloWorld". java.lang.NullPointerException at com.android.ide.eclipse.adt.internal.launch.AndroidLaunchController.launch(Unknown Source) at com.android.ide.eclipse.adt.internal.launch.LaunchConfigDelegate.doLaunch(Unknown Source) at com.android.ide.eclipse.adt.internal.launch.LaunchConfigDelegate.launch(Unknown Source) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:853) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:703) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:866) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1069) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55) 

Solutions Collecting From Web of "Ошибка запуска Eclipse при попытке запустить приложение для Android"

В моем случае проблема исчезла, когда я выбрал AVD. Я использовал проект eclipse, и в конфигурации запуска был действительный AVD, но он не был проверен. Как только я установил флажок, проблема исчезла.

С уважением Камеш

Я щелкнул правой кнопкой мыши над файлом manifest.xml, выбрал опцию Run As -> Run Configurations -> на вкладке Target и выбранном AVD. Я использую Eclipse Helios для Linux 32b,

Я щелкнул правой кнопкой мыши над файлом manifest.xml, выбрал опцию Run As -> Run Configurations -> на вкладке Target и выбранном AVD

У меня была эта проблема, подтвердите, что у вас есть виртуальное устройство на вашем AVD. Моя ошибка произошла просто потому, что у меня не было виртуального устройства.

Еще одна вещь, которую следует учитывать, заключается в том, что если у вас есть ваше виртуальное устройство, не забудьте всегда устанавливать SDK перед началом работы с AVD. Я забыл об этом и потратил много времени на то, чтобы узнать, почему мой AVD не работает. Как вы ожидаете, что ваше виртуальное устройство будет работать без ОС.

Это всего лишь несколько проблем, с которыми начинающие всегда будут сталкиваться при запуске …

Мои советы, которые нужно подробно описывать, не спешат запускать приложение Hello World

Приложение отлично работало, когда я подталкивал его к физическому устройству, поэтому я решил, что еще немного проверю виртуальные устройства. От запуска «устройств adb.exe» я вижу там виртуальное устройство под названием «эмулятор-5554». Когда я выбираю этот, чтобы запускать, я все равно получаю ошибку, но когда я выбираю «Запустить новое виртуальное устройство», я получаю его Когда я запускаю «avdes list avds», он не отображает первое устройство, поэтому похоже, что плохое устройство было создано каким-то образом, вызывая ошибку. Спасибо за помощь!

Это может быть уже решено, но в случае, если кто-то еще споткнется по той же проблеме. Я решил это, сделав копию проекта, удалив его из рабочей области и снова импортирую. Теперь все работает как шарм. Я считаю, что это началось после того, как я удалил виртуальное устройство из AVD-менеджера.