Запуск приложения в Eclipse открывает новую копию эмулятора вместо запуска

У меня появилось новое странное поведение Eclipse со вчерашнего дня. Когда я хочу запустить приложение и нажимать на зеленую стрелку (значок запуска), вместо этого запускается дополнительная копия эмулятора для запуска приложения. Я удалил из снимков снимков avd и изображений пользовательских данных, но у меня все еще есть эта ошибка. Любые идеи, почему это произошло, и как я могу решить эту проблему?

Нажмите стрелку вниз рядом с этой зеленой кнопкой воспроизведения и выберите опцию «Запустить конфигурации …», когда откроется окно, выделите вкладку «target» рядом с вкладкой Android и затем под строкой «Режим выбора целевого объекта» выберите переключатель с заголовком «Руководство» и кнопку «Применить», которая находится внизу, а затем закройте окно. Поэтому в следующий раз, когда вы нажимаете кнопку запуска (зеленая кнопка со значком воспроизведения), затмения попросят вас запустить проект на запущенном эмуляторе или запустить новый эмулятор для запуска проекта. Я думаю, что это может решить вашу проблему.

  1. Убедитесь, что вы используете правильную версию AVD.

  2. Проверьте, правильно ли работает ваш adb.

Несколько раз все, что вам нужно сделать, это принудительно перезапустить adb

Использовать команды

 adb kill-server adb start-server 

Это должно помочь, так как он перезапустит ваш adb.

Если вы все еще не можете найти устройства под управлением ddms, попробуйте проверить, не заблокирован ли ваш брандмауэр при подключении adb.