Intereting Posts
Когда вид прикреплен и отсоединен? Обновление потока пользовательского интерфейса из AsyncTask в открытом классе Как добавить контент приложения с описанием и предварительным просмотром результатов поиска Google? WebView скрывает мягкую клавиатуру во время loadUrl (), что означает, что клавиатура не может оставаться открытой при вызове javascript Как добавить третью кнопку в диалоговое окно Android Alert? КлассNotFoundException Android Как я могу получить результаты из AlertDialog? Android Stop Emulator из командной строки Как вызвать API Java из потока NDK C ++? ListView с изображениями и текстом Ошибка keytool: java.io.IoException: неправильный формат AVA Android SeekBar устанавливает значение прогресса Как получить список установленных приложений для Android и выбрать один для запуска Ошибка Android appcompat v7 Misconfigured App Извините, myapp не был одобрен для показа в App Center. В приложении для Android-приложений

Eclipse ADT: название проекта «appcompat_v7» создается после создания каждого нового проекта

Ну, я хочу подчеркнуть это и принести все это в эту цепочку, так как остальные темы не имели завершенного ответа, поэтому, прежде чем пропустить в них, вот те нити, о которых я говорил:

Adt не создает мир приветствия по умолчанию, но в командной строке

[Решено] Eclipse ведет себя по-другому при создании нового проекта / активности

ADT ведет себя немного странно с прошлых нескольких дней. Я постоянно обновляю SDK, поэтому я часто запускаю менеджер SDK и загружаю все обновления. Недавно я заметил, что если я создаю новый проект приложения для Android, он не будет создавать MainActivity по умолчанию, даже если я проверил это поле, он не создал Activity под src и больше, чтобы раздражать меня, я не смог реорганизовать что-либо, поэтому я понял Что мне пришлось обновить Eclipse после чтения нескольких сообщений, но теперь, когда я создаю каждый новый проект, он создает раздражающий проект appcompat_v7 с проектом КАЖДЫЙ, скажем, я создаю два новых проекта, которые он создает appcompat_v7_2 …. это сводит меня с ума и Новой библиотекой проекта является проект appcompat_v7. Это становится раздражающим, и не знаю, что здесь происходит !!!! Что мне делать … пожалуйста, спаси меня! Спасибо заранее … Скриншот, чтобы раздражать и парней тоже … 🙂

Сегодня не мой день!

*************** Текущая альтернатива, а не решение ***********************

По состоянию на 12/5/2014 с ADT 23.0.2 Я больше не вижу эту проблему.

Я ждал приемлемого решения по этой проблеме (на данный момент его нет), но один из членов SO направил меня на этот пост https://code.google.com/p/android/issues/detail?id= 66975 . То, что я делаю, описано в одном из приведенных ниже решений, но для людей, которые пришли на этот пост, альтернативой является удаление этого уродливого проекта (если у вас более одного), который был создан, и добавить его (appcompat_v7 ) В качестве библиотеки. Поэтому, если вы создаете другой проект и appcomat_v7_2 … появляется, удалите это и укажите ваш проект на appcompat_v7, сделайте то же самое и для других проектов. Однако по какой-то причине это не рекомендуется, но для меня это работало до сих пор без проблем. Если кто-то ударит по решению, отправьте его здесь. **************** Текущая альтернатива, а не решение **************************** *

Solutions Collecting From Web of "Eclipse ADT: название проекта «appcompat_v7» создается после создания каждого нового проекта"

Папка appcompat_v7 не создается, если я использую

minSdkVersion="14" 

Похоже, что это ошибка затмения. Что вам нужно сделать, так это перейти к свойствам в Android-проекте и в разделе Android. Добавьте библиотеку appcompat_v7 и удалите appcompat_v_7_2 (дубликат). Затем вы можете удалить appcompat_v7_2 как проект затмения. Исправлены все ошибки.

Просто обходной путь.

Проект appcompat – это библиотека для поддержки старых версий Android. Библиотека поддержки была недавно представлена ​​Google – я не знаю, в какой версии Android. Но дело в том, что этот проект создается только при создании Android-проекта для перехода на платформы Android. Я имею в виду, когда вы выбираете старый мини-API, например API 8 (Froyo), но нацеливаете на недавно выпущенные версии, ваш проект должен иметь библиотеку поддержки. В любом случае, создание проекта appcompat_v7 – это некоторая проблема, которая должна быть лучше сконфигурирована поддерживателями плагинов eclipse. Однако вы можете элегантно перевернуть эту проблему, настроив новые API-интерфейсы и включив в путь сборки библиотеку поддержки. Это более элегантно, чем другие, потому что вам лучше сосредоточиться только на одной версии для Android при создании приложения, и когда это будет сделано, у вас есть аутентичная версия вашего приложения, которую вы можете использовать в качестве формы для поддержки других версий, Либо старше, либо новее.