Intereting Posts
Сканирование всех устройств Wi-Fi рядом с телефоном Android Datepicker Fragment – Как сделать что-то, когда пользователь устанавливает дату? Заполнение ListView на фрагменте после выполнения Async из Activity Android usb мыши правой кнопкой мыши правильное поведение (ICS) Ресурсы, указанные в манифесте, не могут изменяться по конфигурации Служба Android расширяет ResultReceiver для IntentService, как реализовать CREATOR? Синхронизация модели частичной базы данных с сервера на клиент Любое обходное решение для сохранения намерения в настройках? Почему выход java.exe со значением 1 в студии Android Как запретить ScrollView перехватывать события щелчка / касания представления позади него? Как изменить значок APP динамически в android Передняя камера в Camera2 не захватывает изображение Сбой эмулятора Nexus7 после его создания Содержимое EditText внутри ExpandableListView исчезает при нажатии следующего заголовка ExpandableListView Селектор с атрибутом android: drawable = "@ color / transparent"

Не удается обновить Eclipse ADT до 22

Я хотел экспортировать свои проекты в Android Studio, но Eclipse не обновляется …

До сих пор я добавил как в http URL-адрес источника обновлений , переместил ADT за пределы Program Files , удалил флаг «Только чтение» во всех файлах, обновил sdk и все новые компоненты , но когда я ищу обновления Eclipse ничего не находит, и если я установлю «Android Developer Tools» с помощью «Установить новое программное обеспечение», появится этот длинный журнал ошибок.

Любая идея или вы просто хотите снова загрузить ADT?

An error occurred while collecting items to be installed session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.android.ide.eclipse.adt,22.0.0.v201305140200--675183 No repository found containing: osgi.bundle,com.android.ide.eclipse.adt.package,22.0.0.v201305140200--675183 No repository found containing: osgi.bundle,com.android.ide.eclipse.base,22.0.0.v201305140200--675183 No repository found containing: osgi.bundle,com.android.ide.eclipse.ddms,22.0.0.v201305140200--675183 No repository found containing: osgi.bundle,org.eclipse.ant.launching,1.0.200.v20120530-1204 No repository found containing: osgi.bundle,org.eclipse.ant.ui,3.5.301.v20121210-210948 No repository found containing: osgi.bundle,org.eclipse.emf.edit,2.8.0.v20130125-0826 No repository found containing: osgi.bundle,org.eclipse.jdt,3.8.1.v201302041200 No repository found containing: osgi.bundle,org.eclipse.jdt.apt.core,3.3.500.v20120522-1651 No repository found containing: osgi.bundle,org.eclipse.jdt.apt.pluggable.core,1.0.400.v20120522-1651 No repository found containing: osgi.bundle,org.eclipse.jdt.apt.ui,3.3.300.v20120522-1651 No repository found containing: osgi.bundle,org.eclipse.jdt.compiler.apt,1.0.600.v20130116-050536 No repository found containing: osgi.bundle,org.eclipse.jdt.compiler.tool,1.0.200.v20130116-050536 No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.8.3.v20130121-145325 No repository found containing: osgi.bundle,org.eclipse.jdt.core.manipulation,1.5.0.v20120523-1543 No repository found containing: osgi.bundle,org.eclipse.jdt.debug,3.7.101.v20120913-153601 No repository found containing: osgi.bundle,org.eclipse.jdt.debug.ui,3.6.100.v20120530-1425 No repository found containing: osgi.bundle,org.eclipse.jdt.doc.user,3.8.2.v20130121-200410 No repository found containing: osgi.bundle,org.eclipse.jdt.junit,3.7.100.v20120523-1543 No repository found containing: osgi.bundle,org.eclipse.jdt.junit.core,3.7.100.v20120523-1257 No repository found containing: osgi.bundle,org.eclipse.jdt.junit.runtime,3.4.301.v20120914-131016 No repository found containing: osgi.bundle,org.eclipse.jdt.junit4.runtime,1.1.200.v20120523-1257 No repository found containing: osgi.bundle,org.eclipse.jdt.launching,3.6.101.v20130111-183046 No repository found containing: osgi.bundle,org.eclipse.jdt.ui,3.8.2.v20130107-165834 No repository found containing: osgi.bundle,org.eclipse.wst.common.frameworks,1.2.200.v201203141800 No repository found containing: osgi.bundle,org.eclipse.wst.common.frameworks.ui,1.2.201.v201208292200 No repository found containing: osgi.bundle,org.eclipse.wst.common.modulecore,1.2.201.v201301092200 No repository found containing: osgi.bundle,org.eclipse.wst.common.modulecore.ui,1.0.201.v201208241600 No repository found containing: osgi.bundle,org.eclipse.wst.common.project.facet.core,1.4.300.v201111030424 No repository found containing: osgi.bundle,org.eclipse.wst.common.snippets,1.2.200.v201204260225 No repository found containing: osgi.bundle,org.eclipse.wst.common.uriresolver,1.2.0.v201203071939 No repository found containing: osgi.bundle,org.eclipse.wst.dtd.core,1.1.600.v201205171933 No repository found containing: osgi.bundle,org.eclipse.wst.dtd.ui,1.0.700.v201203081826 No repository found containing: osgi.bundle,org.eclipse.wst.internet.cache,1.0.600.v201203071939 No repository found containing: osgi.bundle,org.eclipse.wst.sse.core,1.1.702.v201301241617 No repository found containing: osgi.bundle,org.eclipse.wst.sse.ui,1.3.102.v201301162301 No repository found containing: osgi.bundle,org.eclipse.wst.standard.schemas,1.0.501.v201301091615 No repository found containing: osgi.bundle,org.eclipse.wst.validation,1.2.402.v201212031633 No repository found containing: osgi.bundle,org.eclipse.wst.validation.ui,1.2.400.v201204260100 No repository found containing: osgi.bundle,org.eclipse.wst.xml.core,1.1.702.v201301101836 No repository found containing: osgi.bundle,org.eclipse.wst.xml.ui,1.1.302.v201301172222 No repository found containing: osgi.bundle,org.eclipse.wst.xsd.core,1.1.700.v201204102147 No repository found containing: osgi.bundle,org.eclipse.wst.xsd.ui,1.2.500.v201203081826 No repository found containing: osgi.bundle,org.junit,4.10.0.v4_10_0_v20120426-0900 No repository found containing: osgi.bundle,org.junit4,4.8.1.v20120523-1257 No repository found containing: osgi.bundle,overlay.com.android.ide.eclipse.adt.overlay,22.0.0.v201305140200--675183 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.adt,22.0.0.v201305140200--675183 No repository found containing: org.eclipse.update.feature,com.android.ide.eclipse.ddms,22.0.0.v201305140200--675183 No repository found containing: osgi.bundle,org.eclipse.jdt.annotation,1.0.1.v20130111-135246 No repository found containing: org.eclipse.update.feature,org.eclipse.jdt,3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 No repository found containing: binary,org.eclipse.jdt_root,3.8.2.v20130116-090414-8-8nFu3FNOfwKLRuqgXKIy9z0I83 No repository found containing: org.eclipse.update.feature,org.eclipse.wst.common_core.feature,3.4.2.v201212051536-7B7EFMVF7RZHOkJkNwS4TV No repository found containing: org.eclipse.update.feature,org.eclipse.wst.common_ui.feature,3.4.2.v201212051536-7C7AFeFEdhOaweLhCnQfylKlOxT5UW No repository found containing: org.eclipse.update.feature,org.eclipse.wst.xml_core.feature,3.4.2.v201211061806-7C7OFm9F7RZHQVHiOz-P0Up No repository found containing: org.eclipse.update.feature,org.eclipse.wst.xml_ui.feature,3.4.2.v201211061806-7H7GFeJDxumUrsn5qkiQgOEhsz0p60HAmPyU6VX 

Solutions Collecting From Web of "Не удается обновить Eclipse ADT до 22"

Я обновил свои инструменты до r22, используя SDK Manager и плагин ADT, используя Eclipse «Проверка обновлений». По какой-то причине у меня все еще было:

Для Android SDK требуется Android Developer Toolkit версии 22.0.0 или выше

Я решил это, переустановив плагин Eclipse ADT с помощью функции «Установить новое программное обеспечение» Eclipse и используя https://dl-ssl.google.com/android/eclipse/ в качестве URL-адреса репо.

Вы можете напрямую скачать ADT22.zip

Ну, мне просто надоело возиться с затмением, поэтому я полностью стер его и переустановил его с необходимыми и завершенными сюжетами, мне очень больно, когда Eclipse ломает меня каждый раз, когда я должен его обновлять.

Таким образом, самый простой и быстрый способ – переустановить. Иногда попытки исправить что-то бесполезно.

Я также выполнил шаги 1,2,3,4 … но, как указано выше, это не сработало для меня, пока я не снял флажок «Свяжитесь со всеми сайтами обновления во время установки, чтобы найти нужное программное обеспечение» в диалоговом окне «Установка», когда я это сделал »Install Новое программное обеспечение ".

Надеюсь, проблема решена долго. Я столкнулся с подобными проблемами, обновляя ADT 21 до 22 с Ubuntu 12.10

Я только что запустил ADT из командной строки в качестве SUPERUSER, а затем попробовал то же самое:
Справка> Установить новое программное обеспечение> Сайт обновления ADT и вуаля, проблема исчезла.

Пойдите, чтобы помочь, установить новое программное обеспечение и выбрать из раскрывающегося меню Android Developers Tools, а также ссылку https://dl-ssl.google.com/android/eclipse/ рядом с ней. После этого выберите обновления, которые будут отображаться ниже.

Затем нажмите «Далее», выберите «Принять» и «Готово». Это загрузит обновления.

ИЛИ Альтернативно добавьте ADT еще раз, как вы изначально, указав имя и указав URL-адрес как https://dl-ssl.google.com/android/eclipse/.

Надеюсь, что это работает!

Чтобы добавить к принятому ответу, это не сработало для меня, пока я не снял флажок «Связаться со всеми сайтами обновлений во время установки, чтобы найти нужное программное обеспечение» в диалоговом окне «Установка», когда я «Установил новое программное обеспечение».

Снимите флажок «Свяжитесь со всеми сайтами обновлений во время установки, чтобы найти необходимое программное обеспечение». См.: Не удается установить Android ADT 21.1 на eclipse Juno (Windows 7) после обновления до SDK 21.1

Я столкнулся с той же проблемой, и следующие шаги для меня работали: 1. Выход из eclipse 2. Запуск eclipse в качестве администратора 3. Перейдите в справочную службу, установите новое программное обеспечение 4. Выберите из раскрывающегося списка (или напрямую вставьте эту ссылку): https://dl-ssl.google.com/android/eclipse/ 5. Нажмите «Далее» и следуйте другим инструкциям.

Это загрузит обновления. Теперь перезапустите adt.

Я думаю, проблема с eclipse. Ранее ур загрузил пакет android sdk manager. Это означает, что plz u может загрузить сумасшедший обгон и установить и использовать для этого существующий sdk. Решить проблему