Intereting Posts
Как сделать этот простой фрагмент диалога полупрозрачным Преобразование JSONarray в ArrayList Android: вызов методов в потоке пользовательского интерфейса из метода AsyncTask doInBackground Воспроизвести SWF-файл в webViewClient на ICS? Приложение не совместимо с устройством, которое я использую для его разработки? Java.lang.NullPointerException: попытка вызвать виртуальный метод 'java.io.File com.parse.ParsePlugins.getParseDir ()' для ссылки на нулевой объект Android: добавление простого фрагмента Пользовательская галерея с изображениями и видео в android для выбора нескольких элементов Не удалось просмотреть комментарии Facebook на Android WebView через локальный HTML-код. ExpandableListView groupView checkbox отключение других групповых просмотров Просмотреть предварительный просмотр навигационного ящика Видео + аудиозапись Android Как получить миниатюры youtube с помощью клиентской библиотеки Google API для Java Как создать массив массивов с данными курсора в Android Как добавить горизонтальную 1px белую линию под кнопкой в ​​относительной компоновке?

Не нашел класс по пути: dexpathlist

Серьезно, я не знаю, что делать, чтобы решить эту проблему. Мой проект Android отлично работал, пока мне не понадобилось импортировать библиотеку с Maven. С тех пор все начало рушиться.

Что происходит: Когда я запускаю свое приложение, на LogCat появляется следующая ошибка, и андроид сообщает, что мое приложение перестало работать. Я искал эту подобную ошибку здесь И на остальной части Интернета, но все, что люди действительно не работали для меня.

Ошибка: java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.example.buscaserra/com.buscaserra.main.ActivitySplash}: java.lang.ClassNotFoundException: Didn't find class "com.buscaserra.main.ActivitySplash" on path: DexPathList[[zip file "/system/framework/com.google.android.maps.jar", zip file "/data/app/com.example.buscaserra-2.apk"],nativeLibraryDirectories=[/data/app-lib/com.example.buscaserra-2, /vendor/lib, /system/lib]]

Манифест и пакеты: манифестпакеты

Путь сборки: buildpath

Пожалуйста, я не знаю, что еще делать. Крайний срок моего проекта близок и в отчаянии. Заранее спасибо.

Та же проблема здесь. Что для меня работало, это добавить android-support-v4.jar в качестве lib и убедиться, что он был проверен в свойствах проекта -> Путь сборки -> Заказ и экспорт. Здесь упоминалось

У меня была такая же проблема, когда я переместил папку проекта с Linux-машины на Mac.

Что я сделал:

  1. Закрыть проект
  2. Удалите файл .iml
  3. Импортируйте проект, используя «Создать новый проект с использованием существующего кода»

Я использую IntelliJ.

Приветствия.

Я сделал следующие шаги для решения проблемы в Android Studio.

  • Открыть файл ./app/build.gradle
  • Уменьшить compileSdkVersion (например, 22 -> 21)
  • Щелкните 'sync project with gradle file'
  • Вернуться к исходной команде compileSdkVersion (например, 22)
  • Щелкните 'sync project with gradle file'

Перекомпилировать и работать.

Есть ли у вас какие-либо требуемые проекты по пути сборки? Невозможно рассказать на экране, но проверьте вкладку «Проекты». Возможно, вы случайно добавили проектную библиотеку в качестве требуемого проекта. Удалите проект со вкладки «Проекты», а затем выполните проект -> свойства. Нажмите Android, вместо этого добавьте проект в качестве библиотеки …

Убедитесь, что все совместимые библиотеки lib, которые вы используете в своем основном проекте (например, android-support-v4.jar), являются теми же версиями, что и в любом из проектов, которые ссылаются на ваш основной проект.

У меня была такая же проблема, и было решено было скопировать и вставить файл android-support-v4.jar из другого проекта библиотеки (что мой основной проект ссылался) и вставить его в папку моего основного проекта / libs.

Я пробовал очистить и перестроить проект, и это сработало для меня

Я должен понять проблему, просто увидев «ошибки dex». Но для устранения проблемы потребовалось полдня. Я исправить это, следуя инструкциям на странице разработчиков Android: https://developer.android.com/studio/build/multidex.html

Сначала добавьте это в мой gradle.build:

 defaultConfig { ... minSdkVersion 14 targetSdkVersion 21 ... // Enabling multidex support. multiDexEnabled true } dependencies { compile 'com.android.support:multidex:1.0.0' } 

Затем я расширяю класс приложения (или объявляю класс приложения в AndroidManifest.xml или переопределяю функцию attachBaseContext ()), как описано в документе класса MultiDexApplication на странице. Это устранило мою проблему.