CordovaResourceApi импортирует неразрешенный телефонный зазор

Я использую phonegap-2.9.0 с файловым плагином. Когда я создаю проект для платформы Android, он создает два пакета в папке src/ :

 org.apache.cordova.file org.apache.cordova.filetransfer 

Я получаю ниже ошибок в этих двух пакетах:

1 – org.apache.cordova.file.FileUtils

 Method testSaveLocationExists() from the type DirectoryManager is not visible Method getFreeDiskSpace() from the type DirectoryManager is not visible Method testFileExists() from the type DirectoryManager is not visible 

2 – org.apache.cordova.filetransfer.FileTransfer

 import org.apache.cordova.CordovaResourceApi unresolved import org.apache.cordova.CordovaResourceApi.OpenForReadResult unresolved 

Может кто-нибудь, пожалуйста, скажите мне, что я должен сделать, чтобы решить эти проблемы?

Благодарю.

Solutions Collecting From Web of "CordovaResourceApi импортирует неразрешенный телефонный зазор"

У вас две проблемы.

1) Версия Phonegap устарела

2) Способ установки плагина:

-> phonegap plugin добавить "urlofplugin" или "/ path" "

-> Android-приложение

-> телефонная заготовка

-> сборка телефонных звонков

Иногда плагин имеет другую установку по умолчанию, файлы должны менять платформу.

Ну, я не знаю, смогу ли я тебе помочь, но у меня были подобные проблемы. Когда я установил именно эти два плагина, я тоже получил ошибку. Другой, который я обычно не помню, что-то связано с отсутствующим файлом, который я могу легко найти в файловом менеджере. Во всяком случае, что мне помогло:

  1. Я обновился до более новой версии, если вы можете мне посоветоваться.
  2. После установки плагинов через кордову cmd api (командная строка .nodejs … вы знаете, что я имею в виду) Я забыл построить сам api. Это звучит глупо, но я использовал wp8 и, таким образом, использовал шаблон для визуальной студии. Студия дала мне ошибку, процесс сборки (в cmd) также дал ошибки, но был исправлен путем обновления до более новой версии.

Вам нужно настроить путь сборки, а затем добавить библиотеку из внешнего источника и выбрать библиотеку, после чего она разрешит или вы сможете скопировать и вставить файл .jar библиотеки кордовой библиотеки в вашу папку lib. То он удалит, если не произойдет, тогда скажите мне …….

Я не уверен, что это сработает, но сначала удалите эти плагины с помощью CLI phonegap / cordova и переустановите его в корневой папке приложения с помощью CLI только следующим образом:

 phonegap local plugin add <required plugin> 

Это работало для меня после переустановки.