Intereting Posts
Получить строку, дату, время и int из базы данных sqlite в android Андроид при возврате к активности уничтожается и не возобновляется Ошибка: – Выполнение неудачно для задачи ': app: dexDebug' в андроид-студии Проблемы с ImageView Android-фрагмент вкладки хоста + просмотрщик? Как найти адрес mac bluetooth программно в Android api уровня 19 Извлечение / изменение видеокадров на Android Android Studio не удается отладить с ошибкой org.gradle.process.internal.ExecException Поиск местоположения пикселов элемента Listview, кажется, возвращает неправильное значение Android Column GridView, переменная ширина, такая как приложение GooglePlus «Дублируйте файл lib, скопированный в APK-META-INF / license.txt» в Android Studio Реализация Android PlusClient и получение токена Копирование каталогов и файлов из папки res / raw на SD-карту – андроид Камера Android: пустой файл в методе onActivityResult Поиск не отвечает при нажатии на панели инструментов AppCompat

Не удалось решить: com.google.firebase: firebase-core: 9.6.0

Все было в соответствии с документацией FB, но при компиляции я все еще получаю следующую ошибку:

Error:(44, 13) Failed to resolve: com.google.firebase:firebase-core:9.6.0 

Мой менеджер SDK говорит, что все в актуальном состоянии:

 Google Play services Rev. 33 installed Google Repository Rev. 35 installed 

Это мое содержимое build.gradle:

 apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion '23.0.3' defaultConfig { applicationId "xxxx.xxxx" minSdkVersion 16 targetSdkVersion 23 versionCode 14 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { // Support libraries compile 'com.android.support:appcompat-v7:23.1.1' compile 'com.android.support:design:23.1.1' // Google APIs // Note: Avoid compiling the entire play-services package. compile 'com.google.android.gms:play-services-gcm:9.4.0' compile 'com.google.android.gms:play-services-location:9.4.0' compile 'com.google.android.gms:play-services-maps:9.4.0' compile 'com.google.android.gms:play-services-places:9.4.0' compile 'com.google.maps.android:android-maps-utils:0.4.4' compile 'org.jsoup:jsoup:1.9.2' compile 'com.google.code.gson:gson:2.7' compile 'io.branch.sdk.android:library:2.+' compile 'com.google.firebase:firebase-core:9.6.0' //<-- CAUSING TROUBLE } apply plugin: 'com.google.gms.google-services' 

Это мой корневой уровень build.gradle:

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.1.3' classpath 'com.google.gms:google-services:3.0.0' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

Почему он не компилируется?

Попробуйте compile 'com.google.firebase:firebase-messaging:9.4.0' вместо compile 'com.google.firebase:firebase-core:9.6.0'

Ответ @Lorenzo Quiroli, возможно, поможет вам, вам нужна такая же версия Firebase и сервисов Google Play.

В моем случае у меня было все, что было в 9.6.0, но все равно получалось сообщение об ошибке. Я решил его, обновив последние версии google-play-сервисов и репозитория Google через SDK-менеджер:

Введите описание изображения здесь

Теперь я знаю, что это не поможет вам, потому что вы уже обновили их, но это может помочь кому-то другому.

Вам нужно использовать ту же версию Firebase и сервисов Google Play. Поэтому, если вы хотите обновить до Firebase 9.6.0 SDK, вы также должны обновить другие зависимости:

 compile 'com.google.android.gms:play-services-gcm:9.6.0' compile 'com.google.android.gms:play-services-location:9.6.0' compile 'com.google.android.gms:play-services-maps:9.6.0' compile 'com.google.android.gms:play-services-places:9.6.0'