Невозможно импортировать com.google.android.maps.MapView

К сожалению, после долгого дня поиска я не нашел ничего полезного для меня.

Моя проблема в том, что я не мог использовать «расширить MapActivity» или, скорее, импортировать библиотеку. Я попытался использовать «API Google» в «Android API», как рекомендуется в некоторых других потоках, но проблема в том, что у меня нет «API Google» в моем SDK Manager для загрузки или выбора.

Мой Android SDK Manager Итак, у меня в «Android SDK Manager» только Android Apis от «Android 1.5 (API 3)» до «Android 4.0.3 (API 15)» и «API Google».

Вот пример, где «Google API» доступен в «Android 4.0.3 (API 15)« Установка API Google …

Есть ли возможность загрузить или импортировать «Google API» по-другому или я делаю что-то неправильно?

У меня была та же проблема с другим решением, я

  1. Щелкнув правой кнопкой мыши на моем проекте в Package Exploere и выбрав «Путь сборки -> Настроить путь сборки»,
  2. Выбранный «Путь сборки Java» и вкладка «Библиотеки»
  3. Выбрано «Добавить внешнюю банку»
  4. Перешел на мой sdk / add-ons / addon-google_apis_google_inc _- / libs
  5. Выбранные "maps.jar"

Затем я смог импортировать com.google.maps. *

Вы можете добавить тег «Android» на свой вопрос, чтобы получить лучшую помощь.

«API Google» следует указывать в «некоторых» API Android в качестве подкарта в Android SDK Manager. Я только что проверил своего менеджера SDK, и Google Apis можно выбрать и установить в Android 1.6, 2.1 и 4.0

Надеюсь, это поможет, если не повторная загрузка и переустановка менеджера Android SDK? Менеджер Android SDK

Попробуйте добавить в файл build.gradle следующее:

dependencies { compile 'com.google.maps.android:android-maps-utils:0.3+' }