Intereting Posts
Неудачное разрешение: Lcom / google / devtools / build / android / desugar / runtime / ThrowableExtension; Где найти информацию о команде оболочки «service call» для Android? Ошибка приложения при создании стопки Android-приложение, которое должно быть установлено только на телефоне, а не на планшетах Как некоторые приложения для Android становятся больше, чем рекомендуемые значки? Добавление плагинов Cordova / Phonegap за прокси Открыть образцы CV для загрузки OpenCV Manager Как интегрировать библиотеку ZXing в Android Studio для сканирования штрих-кодов? Есть ли способ использовать в моем приложении не общедоступные ресурсы Android? OnFling в ListView, Получить информацию об использовании Ошибка Android при добавлении spinnerSelector, идентификатор ресурса не найден Android NSD не обнаруживает всех сервисов Android: Сброс позиции анимации после завершения Через некоторое время мое приложение зависает во время прокрутки WebView, говоря «не удалось заблокировать поверхность», Ограничение размера на прилагаемом Parcelable?

Не удалось разрешить: com.google.android.gms: play-services-gcm: 7.5. +

Я пытаюсь включить GCM в свое приложение.

Я продолжаю получать это сообщение об ошибке:

Не удалось выполнить: com.google.android.gms: play-services-gcm: 7.5. + | Установка репозитория и проект синхронизации | Показать в диалоге Структура проекта

Если я попытаюсь установить репозиторий и проект синхронизации, я получу эту ошибку:

Загрузка информации SDK … Игнорирование неизвестного фильтра пакетов «extra-google-m2repository» Предупреждение: фильтр пакетов удалил все пакеты. Нечего устанавливать. Повторите попытку обновления без фильтра пакетов.

Вот мой файл градиента:

apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 22 buildToolsVersion "22.0.1" ... dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.2.1' compile 'com.google.android.gms:play-services-gcm:7.5.+' 

// Файл сборки верхнего уровня, где вы можете добавить параметры конфигурации, общие для всех подпроектов / модулей.

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.2.3' classpath 'com.google.gms:google-services:1.3+' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

Solutions Collecting From Web of "Не удалось разрешить: com.google.android.gms: play-services-gcm: 7.5. +"

Не могли бы вы проверить, что необходимые пакеты в Android SDK Manager are up to date.

И использовать

 compile 'com.google.android.gms:play-services-gcm:7.5.0' 

Надеюсь, это поможет вам.

Изменение с 7.5.+ 7.5.0 исправило эту проблему для меня. Я не уверен, почему шаблон вызывал проблему.

Я однажды столкнулся с такой же ошибкой после обновления Android Studio и SDK.

Вы можете попытаться использовать 'com.android.tools.build:gradle:1.3.0' вместо 'com.android.tools.build:gradle:1.2.3' в файле проекта gradle.

Обновление SDK разрешило эту проблему для меня.

Я знаю, что на этот вопрос был дан ответ, но просто добавьте что-то для тех, кто сталкивается с подобной ошибкой и видит эту страницу.

При обновлении зависимостей (чтение библиотек поддержки Google) при обновлении обычно появляется всплывающее окно с обновленной версией, а ваш проект использует более старую версию Google Play Services (смотрите в Android SDK Manager в разделе «Дополнительно»).

Чтобы разрешить это, просто обновите Службы Google Play до последней версии, а затем синхронизируйте файл build.gradle (приложение). Это должно решить аналогичные проблемы.

Для чего это стоит, у меня была эта ошибка, когда я обновлялся с 10.1.1 по 10.2.0. Я попытался использовать 10.2, но обнаружил, что мне пришлось использовать полный номер версии: 10.2.0 (последний вопрос имеет значение). Надеюсь, это поможет кому-то.

Для меня – помощь:

  1. Перейти в Инструменты -> Android -> SDK Manager
  2. В Android SDK на вкладке выбора списка слева Инструменты SDK
  3. Проверить все обновления пакетов
  4. Вам нужно много свободного места на диске и много времени (для меня с диском SSD требуется около 1 часа)

После этого ваш проект должен работать нормально.