Intereting Posts
Где я могу найти хорошие игры с открытым исходным кодом для ускорения процесса обучения? Печать EditText $ при нажатии 4 OnItemClickListener, получающий данные из модели Макет перепутался при открытии диалога Использование EditTextPreference с двумя полями ввода пользователя IAB consumePurchase () больше не работает для статического ответа android.test.purchased Динамический пользовательский интерфейс Android ListView с фрагментом Различать одиночные диалоги с помощью DialogInterface.OnClickListener Как использовать как HTTPS, так и HTTP для анализа данных JSON в Android? W / unknown: ViewManagerPropertyUpdater: Не удалось найти созданный установщик для класса com.facebook.react. * Как динамически изменять высоту ActionBar из фрагмента Android ViewPager с фоновым изображением Parallax Как динамически добавлять страницу в FragmentStatePagerAdapter Есть ли способ использовать пользовательское хранилище ключей при создании приложения для Android в режиме отладки в режиме ant?

Не удалось найти: com.android.support:support-v4:22.2.0

Я пытаюсь сделать приложение, но теперь, кажется, есть некоторая ошибка с файлами gradle. Он работал нормально, пока я не обновил библиотеки поддержки. Я работал с api 21, который работал нормально, но затем я обновился до api22 и соответствующим образом изменил файлы градиента. Теперь эта ошибка появляется.

Error:Failed to find: com.android.support:support-v4:22.2.0 

Это мой текущий файл gradle:

 apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.1" defaultConfig { applicationId "com.example.sampleapp" minSdkVersion 12 targetSdkVersion 22 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.2.0' compile 'com.android.support:recyclerview-v7:22.2.0' compile 'com.jakewharton:butterknife:6.1.0' } 

Любая помощь будет оценена по достоинству.

Если это может помочь кому-то, после многих испытаний и ошибок я обнаружил, что я нацелился на неправильную версию SDK (более старую) в файле build.gradle, соответствующем «library». Чтобы изменить это, вы можете сделать это вручную или перейти в меню настроек модуля (щелкните правой кнопкой мыши по папке проекта -> «Открыть параметры модуля». Затем в «library» – «Свойства» вы можете изменить «Скомпилировать Sdk» и «Версии инструментов сборки»

Введите описание изображения здесь