Не удалось найти com.android.support:appcompat-v7:24.2.0

Сегодня я обновил новый SDK, тогда мой проект вызвал серьезный удар. Я уже загрузил Android Support Repository, но он все равно не работает. Ошибка: возникла проблема при настройке проекта: app.

Не удалось разрешить все зависимости для конфигурации: app: _debugCompile. Не удалось найти com.android.support:appcompat-v7:24.2.0. Поиск в следующих местах: файл: / C: / Program Files / Android / Android Studio / gradle / m2repository / com / android / support / appcompat-v7 / 24.2.0 / appcompat-v7-24.2.0.pom файл: / C: / Program Files / Android / Android Studio / gradle / m2repository / com / android / support / appcompat-v7 / 24.2.0 / appcompat-v7-24.2.0.jar https://jcenter.bintray.com/com/ Android / support / appcompat-v7 / 24.2.0 / appcompat-v7-24.2.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/24.2.0/appcompat-v7-24.2 .0.jar : / C: /Users/Owner.KFW-39238/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/24.2.0/appcompat-v7- Файл 24.2.0.pom: / C: /Users/Owner.KFW-39238/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/appcompat-v7/24.2.0/appcompat-v7 -24.2.0.jar файл: / C: /Users/Owner.KFW-39238/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/appcompat-v7/24.2.0/appcompat- Файл v7-24.2.0.pom: / C: /Users/Owner.KFW-39238/AppData/Local/Android/sdk/extras/google/m2 Репозиторий / com / android / support / appcompat-v7 / 24.2.0 / appcompat-v7-24.2.0.jar Требуется: Счет-фактура: приложение: неуказано

Solutions Collecting From Web of "Не удалось найти com.android.support:appcompat-v7:24.2.0"

Поскольку последняя версия библиотеки поддержки в соответствии со v7:24.2.1 изменений в библиотеке поддержки – v7:24.2.1 а не v7:24.2.0 измените свой build.gradle на v7:24.2.1 :

 compile "com.android.support:appcompat-v7:24.2.1" 

У меня была аналогичная проблема сегодня вечером после того, как я обновил Android SDK Tools. Я пошел в файл app / build.gradle. До раздела зависимостей. Две из моих зависимостей были выделены, указав, что я должен перейти на более новую версию. Я обновился до версии, и ошибка исчезла. Для моей ситуации я использовал 24.2.1 библиотек, вызвавших ошибку.

У меня была схожая проблема. После изменения compileSdkVersion до 24 , обновить репозиторий поддержки android и изменить версию appcompat, проблема решена.

 compile "com.android.support:appcompat-v7:24.2.1" 

После обновления sdk в соответствии с вашими потребностями, и если эта ошибка показывается, возможно, вы не установили версию правильно. Вы можете сделать это следующим образом: Создать новый проект. Перейдите в файл градиента,

 compile 'com.android.support:appcompat-v7:24.0.0-alpha2' 

Может быть, вам нужно изменить их, чтобы сравнить их тоже.

 minSdkVersion targetSdkVersion