Доступна более новая версия com.android.support:appcompat-v7, чем 23.2.1: 24.0.0-alpha1

Появляется следующая ошибка

Доступна более новая версия com.android.support:appcompat-v4, чем 23.2.1: 24.0.0-alpha1 и более новая версия com.android.support:appcompat-v7, чем 23.2.1, доступна: 24.0.0- alpha1

Мой файл build.gradle:

apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.2" defaultConfig { applicationId "com.zkc.i2ctools" minSdkVersion 8 targetSdkVersion 23 } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:support-v4:23.2.1' compile 'com.android.support:appcompat-v7:23.2.1' compile files('libs/core-3.1.0.jar') } 

Gradle построить с ошибкой. Что не так?

    На самом деле, есть ошибка: «Lint не должен предлагать альфа-версию зависимостей библиотеки поддержки» https://code.google.com/p/android/issues/detail?id=203270

    Обновление (21 марта 2016 года)

    Ошибка была объединена с этим https://code.google.com/p/android/issues/detail?id=203321 и исправлена ​​для версии 2.1 Future, 11 марта

    Я считаю, что вы можете ввести в заблуждение этот элемент журнала уровня информации с элементом журнала ошибок. Журналы, подобные этому, будут проходить через ваше приложение. Однако это не означает, что что-либо в вашем приложении нарушено.

    Я не верю, что вам следует обновиться до новых версий appcompat, пока они не выйдут из альфы, если они не содержат критически важных исправлений, которые вам нужны.

    Если он не может построить, это совсем другая история.

    У меня была такая же проблема сегодня утром, и моя сборка не удалась. Затем я добавил, что было предложено в выводе сборки Gradle для соответствующего build.gradle:

     lintOptions { abortOnError false } 

    После этого у меня все еще есть ошибка для соответствующего файла build.gradle, но в итоге сборка выполнена успешно.

    Тем не менее, я нахожу также странным, что альфа-релиз чего-то толкает Lint …