Как обновить appengine-java-sdk, установленный в папке .gradle

Когда я создаю проект Android Studio, он говорит:

******************************************************** There is a new version of the SDK available. ----------- Latest SDK: Release: 1.9.15 Timestamp: Tue Oct 21 21:33:59 EDT 2014 API versions: [1.0] ----------- Your SDK: Release: 1.9.14 Timestamp: Thu Oct 16 16:07:33 EDT 2014 API versions: [1.0] ----------- Please visit https://developers.google.com/appengine/downloads for the latest SDK. 

Я заметил, что в моей папке .gradle есть папка appengine-java-sdk в моей домашней папке:

~ / .gradle / AppEngine-SDK / AppEngine-ява-СДК-1.9.14

Мне нужно загрузить последнюю версию AppEngine SDK отсюда:

https://cloud.google.com/appengine/downloads

Или есть более простой способ обновить его из Android Studio?

Solutions Collecting From Web of "Как обновить appengine-java-sdk, установленный в папке .gradle"

Измените версию из зависимостей градиентов:

 dependencies { appengineSdk 'com.google.appengine:appengine-java-sdk:1.9.18' } 

Затем нажмите «Синхронизировать проект». Он автоматически вытеснит IDE, чтобы загрузить и установить нужную версию.

Если вы используете встроенную поддержку приложения, проверьте свои зависимости от градиента для задней части. Например, это build.gradle из базового модуля в простом проекте:

 dependencies { appengineSdk 'com.google.appengine:appengine-java-sdk:1.9.14' compile 'com.google.appengine:appengine-endpoints:1.9.14' compile 'com.google.appengine:appengine-endpoints-deps:1.9.14' compile 'javax.servlet:servlet-api:2.5' } 

Обновите номер версии для SDK выше, и Gradle должен иметь возможность вывести правильную версию из Maven / JCentral.

Вы не обновляете

Appengine-java-sdk установлен в папку .gradle

Вы загружаете новую версию. Когда вы это делаете, .gradle/appengine-sdk выглядит следующим образом:

Введите описание изображения здесь

Как говорили другие, вы просто загружаете новую версию, изменяя номер версии в зависимостях и выполняете синхронизацию проекта. (У вас должно быть подключение к Интернету)

Если вы используете maven, то просто обновите pom.xml в своем проекте tp последним движком приложений sdk.

 <properties> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> <appengine.target.version>1.9.32</appengine.target.version> </properties>