Кордова App – ошибка инструмента сборки – Gradle

У меня есть приложение кордовы. Не удалось скомпилировать его после переустановки системы.

У меня Error:No installed build tools found. Please install the Android build tools version 19.1.0 or higher. Error:No installed build tools found. Please install the Android build tools version 19.1.0 or higher.

Мой профиль

 export ANDROID_HOME="/home/iamkhush/Android/Sdk/tools" export ANDROID_PLATFORM_TOOLS="/home/iamkhush/Android/Sdk/platform-tools" export ANDROID_STUDIO='/home/iamkhush/Downloads/work/android-studio/bin/' 

У меня есть 19.1.0 с именами 19.1.0 и 23.0.1 на home/iamkhush/Android/Sdk/build-tools

У меня установлен град 2.7.

Введите описание изображения здесь

Что еще я должен изучать, чтобы решить эту проблему? Я считаю, что видел все записи, похожие на это, но не мог заставить его работать.

Вы неверно установили ANDROID_HOME в свой файл ~/.profile . Направьте его только в папку SDK .

 export ANDROID_HOME="/home/iamkhush/Android/Sdk" 

Кроме того, убедитесь, что JAVA_HOME , PATH установлены правильно, и /home/iamkhush/Android/Sdk имеют встроенные инструменты Android SDK версии 19.1.0 или 19.1.0 .

Пожалуйста, запустите следующие команды.

В Windows:

 cd c:\Android\android-sdk\tools\bin 

Не забудьте заменить путь инструмента в соответствии с вашим.

а потом:

 sdkmanager "build-tools;26.0.0" 

Установка переменной окружения ANDROID_HOME в нужный каталог помогла мне: C:\Users\roelo\AppData\Local\Android\sdk\

Убедитесь, что вы правильно установили инструментальные средства для Android SDK версии 19.1.0 .

Откройте Android SDK и проверьте это.