Минимальный уровень API Android для запуска Google Maps Android API v2

Я разработал мобильное приложение, которое использует API Android Google Maps v1, и я планирую перенести его на недавний Google API Android Android v2, как это рекомендовано Google.

Однако мое приложение также предназначено для устройств Android 2.1, и я не могу понять, будут ли v2 Maps работать на таких устройствах. Я нашел некоторую ссылку, предполагающую, что v2 должен работать с уровнями 8 и 10 API ( здесь , здесь и здесь ), при условии, что OpenGL ES 2.0 поддерживается мобильным устройством, но ничего об уровне API 7.

Поэтому мой вопрос: каков минимальный уровень API Android для запуска Google Maps Android API v2?

ТИА!

Solutions Collecting From Web of "Минимальный уровень API Android для запуска Google Maps Android API v2"

API Карт связан с сервисами Google Play и совместим с Android 2.2 и выше. Все устройства с уровнем API Android 8 поддерживают OpenGL 2.0, поэтому устройства с версией Android 2.1 не могут поддерживать Google Maps v2. Вы можете проверить документацию Google .

It'a API Level 8 (Froyo), из-за зависимости Play Services.

Также обратите внимание, что если вы используете уровни API 8-10, вам необходимо использовать SupportMapFragment с помощью библиотеки поддержки Android: http://developer.android.com/tools/extras/support-library.html , поскольку фрагменты были добавлены только в Уровень API 11.

Я думаю, вы пытаетесь в эмуляторе Android,

или,

Вы пытаетесь с планшетом, у которого нет функции GPS, попробуйте устройство с поддержкой GPS, оно должно работать должным образом

Как сказал Бени, он работает с версией Android 2.2 и более поздней версии. Но вам нужна библиотека поддержки Android для версий 2.x, так как она использует фрагменты …