Intereting Posts
Theme.AppCompat.Light.NoActionBar.FullScreen не работает с Android 4.4 Лучший способ реализовать Client <-> Server <-> Архитектура базы данных в приложении для Android? Расписание нескольких задач async в android HttpClient не работает с Handshake Failed в Android 5.0 Lollipop Передача данных между iOS и Android через Bluetooth? Android – java.lang.SecurityException: отказ от разрешения: начало работы SCAN_RESULTS_AVAILABLE_ACTION возвращает пустой список в Android 6.0 Android – как добавить метод щелчка элемента в ArrayAdapter RuntimeException при использовании нового TextInputLayout из библиотеки дизайна поддержки Плагин Phonegap + Facebook с функцией AngularJS Сохранить информацию о пользователе facebook для использования в другой деятельности AlarmManager не работает на нескольких устройствах Работа с дублирующимися записями в AndroidStudio: java.util.zip.ZipException Загрузка текстур в приложение Android OpenGL ES Лучшая практика хранения данных в памяти и базе данных одновременно на Android

Ошибка в изменении уровня API Android?

Когда я создаю новый проект, я добавил API-уровень 14, я завершил свое приложение, и я хочу изменить уровень API до 10,

Я получаю и ошибаюсь в ресурсах -> values-v11 -> style.xml, т. Е. error: Error retrieving parent for item: No resource found that matches the given name 'android:Theme.Holo.Light'.

В ресурсах -> values-v14 -> style.xml

Т.е. error: Error retrieving parent for item: No resource found that matches the given name 'android:Theme.Holo.Light.DarkActionBar'.

Я понял, это может объяснить каждый

Solutions Collecting From Web of "Ошибка в изменении уровня API Android?"

Эти темы доступны на уровне API 11 или выше, поэтому он не будет работать. Потому что вы используете уровень API 10.

Обратитесь к этой ссылке: http://developer.android.com/guide/topics/ui/themes.html

Следуя совету анкиты гахои , я немного искал и решил проблему.

Попробуй это:

Удалите значения папок – 11 'и' values-14 '(если они существуют). Затем, если эта ошибка появляется в окне консоли:

  "No resource identifier found for attribute 'showAsAction' in package 'android'" 

Прочтите ответы на следующие вопросы:

«Идентификатор ресурса не найден для атрибута« showAsAction »в пакете« андроид » (Jason Hanley's)

Как изменить целевую сборку на проекте Android? (Алан Уилл)

Моя цель сборки уже была настроена на нужную версию Android, поэтому я установил ее в «API Google», а затем вернулся к прежней цели.

Случилось со мной в конкретном случае, когда в одном из проектов библиотеки Android была установлена ​​эталонная SDK для API 9. Что меня смутило, так это то, что в журнале ошибок было указано название проекта с правильными настройками, а не проблемное.

Перейдите к значениям-v11 -> style.xml. Заменить код:

 <style name="LightThemeSelector" parent="android:Theme.Light"> 

По коду:

 <style name="LightThemeSelector" parent="android:Theme.Light">