Articles of sdk

Плагин ADT исчез в Eclipse

.. Я пытался установить Google Cloud Messaging для Android-библиотеки, с Экстра в Android SDK Manager. Поскольку он не появился, я обновил Android SDK Tools и Android SDK Platform-Tools до последней версии (как показано здесь: как работает служба Google Cloud Messaging в Android? ). После обновления обоих я до сих пор не мог найти никаких дополнительных […]

Admob 6.2.1 исключение nullpointer

У меня большая проблема, я хочу интегрировать admob в мое приложение для Android, но я получаю исключение nullpointer в графическом макете, когда я пытаюсь интегрировать admob в xml-файл java.lang.NullPointerException at com.google.ads.AdView.onMeasure(SourceFile:670) at android.view.View.measure(View.java:15172) at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4814) at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1390) at android.widget.LinearLayout.measureVertical(LinearLayout.java:681) at android.widget.LinearLayout.onMeasure(LinearLayout.java:574) at android.view.View.measure(View.java:15172) at android.widget.RelativeLayout.measureChildHorizontal(RelativeLayout.java:617) at android.widget.RelativeLayout.onMeasure(RelativeLayout.java:399) at android.view.View.measure(View.java:15172) at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:4814) at android.widget.FrameLayout.onMeasure(FrameLayout.java:310) at android.view.View.measure(View.java:15172) […]

Запуск Android-эмулятора с параметром -noaudio возвращает «qemu-system-i386.exe: -audio: недопустимый параметр»

Я запускаю Windows 10, 64 бит, Android Studio 2.2.2. При создании AVD из AVD-менеджера Android SDK я не вижу возможности полностью отключить звук (ввод и вывод). Я использую Android SDK, который имеет версию Android Tools 25.2.2). В более старшем менеджере AVD я вспоминаю, что есть возможность полностью отключить аудио на AVD. Когда я хочу создать […]

Android SDK – Ссылка на приложение для галереи телефона?

На данный момент в моем приложении я создал небольшое приложение галереи, используя предоставленный виджет, мне нужно это, чтобы выбрать картинку с телефона. Это работает отлично и все, но в презентации очень мало. У меня есть несколько приложений на моем телефоне, которые делают то же самое, но они каким-то образом используют галерею, которая уже находится в […]

Почему для Blackberry и Android SDK нужны старые версии Eclipse IDE?

Я подумал, что вам нужно это делать только для ежевики, но, смотря видео с YouTube, вы начинаете работу с Android, в нем говорится, что вам нужен Eclipse Galileo (3.5.x). Мой вопрос заключается в том, что есть какая-то техническая причина, почему этот SDK-simpy не может поддерживать совместимость с более новыми версиями Eclipse. Есть ли причина для […]

Почему API, внедренный в Honeycomb, работает на Gingerbread?

В документации для DatabaseUtils.concatenateWhere (…) указано, что она поддерживается с уровня API 11+ (HONEYCOMB). Однако при тестировании совместимости на разных устройствах, что на моем Droid X работает Cyanogenmod 7 ночной сборки 98 (на основе имбирных пряников 2.3.5) , вызов метода не только не вызывает крушения, но работает как ожидалось. Является ли это некоторой несогласованностью с […]

Невозможно импортировать ActionBar в Android-приложение с обратной совместимостью

У меня есть приложение для Android, которое предназначено для API 17 и имеет минимальную версию SDK версии 8. Я не заинтересован в предоставлении ActionBar на устройствах с Android API <11, но я бы хотел использовать на устройствах под управлением Android> = 3.0 , Просмотрев stackoverflow, чтобы узнать, как это сделать, я наткнулся на этот вопрос: […]

Библиотека поддержки Android Eclipse: обязательная версия пуста

Я только что загрузил и установил последний пакет ADT для Windows, доступный с веб-сайта разработчика Android. После этого я установил все пакеты в диспетчере SDK, в том числе «Библиотека поддержки Android Rev. 18». Наконец, я установил последний ADT через меню «Справка> Установить новое программное обеспечение …» в Eclipse. Я строго следовал следующему руководству, чтобы создать […]

Как использовать дополнения Android SDK?

Может ли кто-нибудь поделиться некоторыми сведениями о разработке нового дополнения SDK, например, одного API карты Google? Я не могу найти подробную информацию о том, как создать новое дополнение к SDK? Это хороший подход для добавления SDK для подключения к твиттеру, Facebook, приложениям YouTube? Я имею в виду, что библиотека будет содержать методы доступа к API-интерфейсам […]

Ионный: эмулятор: ОШИБКА: В конфигурации AVD отсутствует файл ядра! Эмулятор: ERROR: ANDROID_SDK_ROOT не определено

Я создал приложение с ионной, встроенный в android, а затем, когда я запускаю «ионный эмулятор андроида», я получаю следующую ошибку: «Emulator: ERROR: в конфигурации AVD отсутствует файл ядра! Emulator: ERROR: ANDROID_SDK_ROOT не определено» Я читаю в Интернете, и большинство из них говорит, что мне нужно установить ARM EABI v7a System Image. У меня есть андроид-студия, […]