Articles of maven плагин

Веб-сайт для поиска библиотек android для использования внутри build.gradle

Я помню, что там был веб-сайт, на котором вы могли искать библиотеки Android, и он предоставит вам URL-адрес, который вы можете использовать в файле build.gradle, например: apply plugin: 'android' repositories { mavenCentral() } dependencies { compile 'com.android.support:support-v13:+' compile '<an-url-you-would-put-here>' } К сожалению, я больше не могу его найти, знает ли кто-нибудь об этом? Я думаю, […]

Исключение в потоке «main» java.lang.NoClassDefFoundError: org / codehaus / jackson / JsonParseException

Я использую Twilio для отправки SMS-сообщений из своего веб-приложения, и я почти завершил интеграцию. Он отправляет SMS, но генерируется ошибка, и я не понимаю, почему. Я включил зависимость JSON от этой json и этой ссылки файла, но я все еще получаю сообщение об ошибке. Какую другую банку мне нужно включить? Exception in thread "main" java.lang.NoClassDefFoundError: […]

Как импортировать зависимости AAR от Android, используя Maven в Eclipse?

Примечание. Я использую Maven 3.2.2, Eclipse Luna Это зависит от моего pom.xml, который использует архив Android AAR <dependency> <groupId>com.github.gabrielemariotti.cards</groupId> <artifactId>library</artifactId> <version>1.7.3</version> <type>aar</type> </dependency> Я вижу классы, установленные в папке target / classes. Но когда я пытаюсь использовать классы в AAR, Eclipse показывает класс не может быть разрешен. У меня нет проблем с использованием классов, добавленных […]

Хостинг Gradle артефактов на GitHub

Я знаю, что люди используют GitHub для развертывания артефактов Maven (в новой ветви), но поскольку мы используем Gradle, я хотел бы знать, есть ли простой способ обработки этих зависимостей? У нас есть разные небольшие проекты, которые являются независимыми, но используются нашим основным проектом, и мы хотим управлять этими зависимостями, не включив их в локальную сеть. […]

Включить зависимость от локального репозитория Maven на Android Studio Gradle

Я думаю, что я глуп, или мне что-то недостает – надеюсь, что последнее – но я не могу правильно импортировать зависимость. У меня есть репозиторий в ~ / .m2 / repository, и внутри каталога я вижу развертывание. У maven setting.xml есть <localRepository>${user.home}/.m2/repository</localRepository> Вот файл градиента: dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile project(':lib_facebook') compile […]

Зависимости от игровых сервисов и баз данных (AAR) в Android

Я нашел xml-файл GoogleDependencyFlurryPlugin.xml <dependencies> <dependency><groupId>com.google.android.gms</groupId><artifactId>play-services-base</artifactId><version>8.4+</version></dependency> <dependency><groupId>com.google.android.gms</groupId><artifactId>play-services-basement</artifactId><version>8.4+</version></dependency> </dependencies> И действительно XML-файл GoogleDependencyPlayGameServicesPlugin.xml <dependencies> <dependency><groupId>com.google.android.gms</groupId><artifactId>play-services-games</artifactId><version>8.4+</version></dependency> <dependency><groupId>com.google.android.gms</groupId><artifactId>play-services-plus</artifactId><version>8.4+</version></dependency> </dependencies> Теперь, в какой-то момент прежний файл имел ТОЛЬКО Play-services-base> OR <play-services-basement И это, казалось, вызывало огромную проблему. AndroidJavaException: java.lang.NoSuchMethodError: после запуска на устройстве. Эксперты по Android, это так, если у вас есть «база», у вас должен быть «подвал» … […]

«Peer Not Authenticated», срок действия SSL-сертификата parse.com

Я в настоящее время борется с проблемой «Peer Not Authenticated», а в Android Studio – градиентом. Когда я пытаюсь очистить свой проект, AS говорит мне, что проблема связана с https://maven.parse.com/repo/com/parse/tools/gradle/maven-metadata.xml С интернет-браузером я вижу, что SSL-сертификат * .parse.com истек в четверг 26-го … Я уже пытался заменить «https» на «http», чтобы обойти проверку, но это […]

Обновить зависимость библиотеки maven от андроид-запроса

В настоящее время последняя версия, представленная в коде google, составляет 0.26.7 https://code.google.com/p/android-query/downloads/list Но кувшин в хранилище maven все еще находится в 0.25.9, что больше, чем год назад. http://mvnrepository.com/artifact/com.googlecode.android-query/android-query Нужно ли вообще публично обновлять библиотеку?

Maven release: выполнить не распознает параметры хранилища ключей

Я сгенерировал свой проект, используя архетип версии для Android . В его документации указано, что в файл settings.xml добавлен профиль android-release . Мой ~/.m2/settings.xml выглядит так: <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd"> <profiles> <profile> <id>android-release</id> <properties> <sign.keystore>absolute path</sign.keystore> <sign.alias>my_alias</sign.alias> <sign.storepass>pass</sign.storepass> <sign.keypass>pass</sign.keypass> </properties> </profile> </profiles> </settings> Мой родительский файл pom.xml почти тот же, что и в архетипе […]

Синхронизация градиента Android Studio не удалось найти в библиотеке

Поэтому я работаю над проектом в AndroidStudio 0.8.1 beta, и я хочу использовать библиотеку, которую я нашел в github ( https://github.com/derekbrameyer/android-betterpickers ). Я добавляю зависимость, как она говорит внутри README.md, но когда я пытаюсь синхронизировать проект с файлами градиента, он говорит: Не удалось найти: com.doomonafireball.betterpickers: library: 1.5.2 Вот мой файл build.gradle: apply plugin: 'com.android.application' buildscript […]