Articles of gradle

Количество ссылок метода в файле .dex не может превышать 64k API 17

Я создаю приложение с SugarORM Library, но когда я пытаюсь построить проект для API 17 (не проверял других), он показывает ошибку сборки. Information:Gradle tasks [:app:assembleDebug] :app:preBuild UP-TO-DATE :app:preDebugBuild UP-TO-DATE :app:checkDebugManifest :app:preReleaseBuild UP-TO-DATE :app:prepareComAndroidSupportAnimatedVectorDrawable2330Library UP-TO-DATE :app:prepareComAndroidSupportAppcompatV72330Library UP-TO-DATE :app:prepareComAndroidSupportCardviewV72330Library UP-TO-DATE :app:prepareComAndroidSupportDesign2330Library UP-TO-DATE :app:prepareComAndroidSupportMediarouterV72300Library UP-TO-DATE :app:prepareComAndroidSupportRecyclerviewV72330Library UP-TO-DATE :app:prepareComAndroidSupportSupportV42330Library UP-TO-DATE :app:prepareComAndroidSupportSupportVectorDrawable2330Library UP-TO-DATE :app:prepareComAndroidVolleyVolley100Library UP-TO-DATE :app:prepareComGithubSatyanSugar14Library UP-TO-DATE :app:prepareComGoogleAndroidGmsPlayServices840Library UP-TO-DATE :app:prepareComGoogleAndroidGmsPlayServicesAds840Library […]

Gradle Создайте только аромат

Может ли кто-нибудь сказать мне, можно ли построить только один из моих разных вкусов в командной строке? На данный момент я не видел способ выполнить, например: gradle buildDev Когда Dev является одним из моих разных вкусов. Действительно, я должен выполнить: gradle build И все вкусы строятся. Я бы хотел пропустить некоторые ароматы. Является ли это […]

Android скопирует существующий проект с новым именем в Android Studio

Я хотел бы скопировать проект андроида и создать новый проект из тех же файлов, что и другое имя. Целью этого является то, что у меня может быть вторая версия моего приложения, которое поддерживается рекламой в магазине приложений. Я нашел этот ответ здесь: Android – копирование существующего проекта с новым именем Но его для затмения, как […]

Android Gradle Не удалось зарезервировать достаточно места для кучи объектов

Я установил Android Studio 1.1.0. Я еще ничего не сделал, как начать новое приложение для Android или импортировать что-нибудь. Как-то он пытается что-то построить, и это вызывает ошибку синхронизации. Ошибка: невозможно запустить процесс демона. Эта проблема может быть вызвана неправильной настройкой демона. Например, используется непризнанная опция jvm. Пожалуйста, обратитесь к главе руководства пользователя о демоне […]

Проблема с DexIndexOverflowException после обновления до последней библиотеки приложений и поддержки

Я использую следующие настройки через gradle : compileSdkVersion 21 ANDROID_BUILD_MIN_SDK_VERSION=14 ANDROID_BUILD_TARGET_SDK_VERSION=21 ANDROID_BUILD_TOOLS_VERSION=21.0.2 ANDROID_BUILD_SDK_VERSION=21 У меня также есть следующие настройки в моем файле gradle: compile 'com.android.support:support-annotations:21.0.0' compile 'com.android.support:appcompat-v7:21.0.0' compile 'com.android.support:support-v4:21.0.0' Я всегда получаю ошибку UNEXPECTED TOP LEVEL EXCEPTION . Но когда я делаю 21.0.0 до 20.0.0 он отлично работает … но я не могу получить доступ […]

Добавление локальных файлов .aar в мою структуру градиента

Итак, я создал Android-библиотеку и успешно скомпилировал ее в файл .aar, который я назвал этим aar-файлом: "projectx-sdk-1.0.0.aar" теперь я хочу, чтобы мой новый проект зависел от этого aar, так что я сделал Следует за этой почтой: http://life.nimbco.us/referencing-local-aar-files-with-android-studios-new-gradle-based-build-system/ Но пост смущает меня, так как я не получаю желаемого результата: Имя пакета com.projectx.photosdk : com.projectx.photosdk а модуль […]

Требуется версия Gradle 2.2. Текущая версия 2.10

Я пытаюсь использовать построение градации. Это дает мне ошибку, говоря, что Не удалось применить плагин [id 'com.android.library'] Требуется Gradle версии 2.2. Текущая версия – 2.10. Если вы используете оболочку градиента, попробуйте отредактировать дистрибутивUrl в /home/sanjeewa/workspace/Android/UVCCamera/gradle/wrapper/gradle-wrapper.properties до gradle-2.2-all.zip Но мои gradle-wrapper.properties включают gradle-2.4-all.zip. Я изменил его на gradle-2.2-all.zip. Еще одна проблема. Когда я запускаю gradle -version […]

Конфликт с зависимостью «com.android.support:support-annotations». Разрешенные версии для приложения (23.1.0) и тестового приложения (23.0.1) отличаются

При построении я получаю следующую ошибку: Conflict with dependency 'com.android.support:support-annotations'. Resolved versions for app (23.1.0) and test app (23.0.1) differ. Это мои зависимости от градиента dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.android.support:support-v4:23.1.0' compile 'com.android.support:appcompat-v7:23.1.0' compile 'com.android.support:design:23.1.0' compile 'com.android.support:cardview-v7:23.1.0' compile 'com.android.support:recyclerview-v7:23.1.0' compile 'com.squareup.retrofit:retrofit:1.9.0' compile 'com.squareup.okhttp:okhttp:2.4.0' compile 'com.squareup.picasso:picasso:2.5.2' compile 'com.jakewharton:butterknife:7.0.1' compile 'com.squareup:otto:1.3.8' compile 'com.snappydb:snappydb-lib:0.5.2' compile […]

Не удается разрешить символ «AppCompatActivity»

Я просто пытался использовать Android Studio. Я создал пустой проект и попытался создать Activity который расширяет AppCompatActivity . Unfortunalty Android Studio «говорит», что это Не удается разрешить символ «AppCompatActivity» Я compile "com.android.support:appcompat-v7:22.0.+" в списке зависимостей моего «приложения» и несколько раз перепроектировал проект. Однако я могу использовать ActionBarActivity . Что я делаю не так?

Travis.yml ./gradlew: разрешение отклонено

Использование Travis CI для вызова существующего Android-проекта $ ./gradlew build connectedCheck Я получаю эту ошибку: /home/travis/build.sh: line 45: ./gradlew: Permission denied The command "./gradlew build connectedCheck" failed and exited with 126 during .

Intereting Posts
Ссылка на элемент списка ListView Нажмите состояние строки с кнопкой внутри элемента списка. Как создать ключ RSA ключей хранилища Android с бесконечной достоверностью? Скрыть фиктивную учетную запись для адаптера синхронизации из настроек Не удается получить доступ к внутренним компонентам из источника тестирования с помощью Android Почему эмулятор Android автоматически увеличивает размер ОЗУ и заставляет его не запускать его? Что это значит «xmlns: xliff»? XML Добавление динамического представления в элемент RecyclerView EditText автоматически перейдет на новую строку Glide: Как найти, если изображение уже кэшировано и использовать кешированную версию? Проблема с макетами: SliderDrawer не заполняет родительскую ширину Установить URL-адрес изображения для просмотра изображения Проблема с двойным эскизом Android Corova build –release android всегда выбирает самый высокий уровень api Com.android.support:design:23.3.0 сломан, когда пользовательский вид, используемый в Tablayout Пользовательский адаптер spinner simple_spinner_dropdown_item не отображается правильно