Articles of gradle

Android Studio: Как я могу получить выровненный подписанный выпуск APK?

Я использую Android Studio, а для других проектов, когда я пытаюсь создать подписанный APK, я получаю файл app-release.apk с дальнейшими проблемами. Но в этом конкретном проекте я могу получить только файл app-release-unaligned.apk . Основное отличие от моих других проектов – использование библиотеки transloadit jar и org.apache.httpcomponents, для которой мне пришлось записать поле packagingOptions в мой […]

Лучший способ управлять зависимостями Android Gradle

Я использую «com.android.tools.build:gradle:0.6.+» для создания моего приложения для Android. Известно, что Android dex не может содержать разные версии одной и той же библиотеки. Но как обрабатывать ситуацию, когда зависимость Maven, которую вы хотите использовать, требует некоторой библиотеки, которую вы уже используете, но только другой версии. Пример. Следуя в файле build.gradle: dependencies { compile 'com.android.support:appcompat-v7:+' compile […]

Android: Как изменить определенное имя сгенерированного файла apk в Android Studio?

По умолчанию IDE genarate apk, например app-debug.apk или файл app-release.apk но мне нужно сгенерировать определенное имя Apk приложения. Например: Мое имя приложения – iPlanter, поэтому мне нужно создать iPlanter-debug.apk или iPlanter-release.apk вместо app-debug.apk или app-release.apk соответственно. Благодаря,

Как ограничить использование памяти DEX

Я пытаюсь установить максимальную память, которую DEX-задача может использовать в проекте Android на основе градиента, но не может найти никакой возможности для этого. Моя мотивация для этого заключается в том, что поскольку dex иногда занимает так много памяти, что мой компьютер начинает заменять и полностью перестает отвечать на несколько минут (так что я предпочел бы, […]

Вручную добавление aar с файлом pom / iml зависимости

Поскольку я не могу использовать частный maven для обмена своей библиотекой, я думал об обмене ааром и импортировании в другой проект. Проблема возникает, когда файлы aar и jar не содержат никакой зависимости. Поэтому, как только я вручную импортирую aar в студию android (с помощью Import .JAR / .AA Package), нет никакой зависимости, и мне придется […]

Нет кэшированной версии com.android.tools.build:gradle:1.2.3 для автономного режима

Я установил JetBrains IDEA 15.0.2 с поддержкой android на моем компьютере, который отключен от Интернета. После этого синхронизация проекта дает ошибку, что градиент не существует, поэтому я решаю проблему, загружая градиент 2.2.1 и извлекая его в соответствующее положение. Но после этого возникает новая ошибка синхронизации, в которой говорится: «Нет кэшированной версии com.android .tools.build: gradle: 1.2.3 […]

Не удалось найти метод android () для аргументов в проекте Android Studio

Я пытаюсь выполнить ранговую синхронизацию в своем проекте студии Android, и я продолжаю получать эту ошибку в названии. Мой файл build.gradle // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.2.1' // NOTE: Do not place your application dependencies here; they […]

Gradle: как создать два приложения для каждого аромата с различными папками с ресурсами:

В настоящее время я работаю над приложением, имеющим 5 вариантов, и это часть моих файлов build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.14.0' } } apply plugin: 'com.android.application' repositories { mavenCentral() } android { compileSdkVersion 20 buildToolsVersion '20.0.0' signingConfigs { release { storeFile file("") storePassword "password" keyAlias "alias" keyPassword "password" } } […]

Ошибка: Минимальная поддерживаемая версия Gradle – 2.10, Gradle 3.x еще не поддерживается.

Полное название Я хотел : Ошибка: Минимальная поддерживаемая версия Gradle – 2.10, Gradle 3.x еще не поддерживается. Текущая версия – 2.4. Если вы используете оболочку градиента, попробуйте отредактировать дистрибутивUrl в … \ gradle-wrapper.properties до gradle-2.10-all.zip У меня есть старый проект, который я пытаюсь открыть в Android Studio 2.2 (Preview 6), и когда я пытаюсь создать […]

Трэвис CI потерпел неудачу, потому что не может принять лицензию Constrain Layout

Прежде чем я напишу этот вопрос, я уже ищем тот же вопрос об этом, они сделали экспортную лицензию, потому что все еще используют альфа-версию ограничения. Но теперь андроид уже выпускает стабильную версию компоновки ограничений. Я пробовал много настроек, но все еще не удалось. Мой последний .travis.yml language: android jdk: oraclejdk8 android: components: – platform-tools – […]