Articles of eclipse

Если я напишу приложение с помощью платформы Android 4, приложение будет работать на устройствах Android 2?

Я хочу написать приложение с помощью Android SDK и Eclipse. Я установил платформу Android 4 с помощью диспетчера SDK, но мне интересно, будет ли это приложение работать с устройствами Android 2? Или только устройства Android 4? Благодарю.

Eclipse не доволен одной доступной папкой?

Я создаю приложение для Android с помощью Eclipse. Если у меня есть одна папка Drawable с несколькими PNG-файлами, редактор UI в Eclipse не сможет загрузить изображения, которые я размещаю на ImageButtons. Мне не удалось преобразовать и не удалось разрешить ошибки @drawable в журнале, и кнопки просто отображаются в редакторе пустым. Если я запускаю приложение на […]

Eclipse Android: как использовать проект библиотеки со связанными папками?

Если у меня есть простая андроидная библиотека (установленная с помощью project-> properties-> android-> Library ) со связанными папками, связанные папки не включаются в приложение с помощью библиотеки. Выбор проекта библиотеки добавит ссылку в проект приложения в папку «src» библиотеки и все реальные папки, но она игнорирует любые связанные папки в проекте библиотеки. — Edit: это […]

Android: не удалось создать пользовательский вид в XML

У меня есть пользовательское представление (CoordinateGridView), которое я использую в макете XML (activity_trajectory.xml): <com.android.catvehicle.CoordinateGridView android:id="@+id/coordinateGrid" android:layout_width="fill_parent" android:layout_height="fill_parent" android:layout_alignParentBottom="true" android:layout_alignParentRight="true" /> Я получаю эту ошибку в графическом редакторе: **. КоординаторGridView не удалось создать экземпляр. Ошибка в графическом редакторе Android http://i42.tinypic.com/2w3b9f5.png Это мой конструктор в пользовательском представлении: public CoordinateGridView(Context context, AttributeSet attrs) { super(context, attrs); setFocusable(true); setFocusableInTouchMode(true); […]

Android-эмулятор и AVD не будут работать на Surface Pro

Я установил 64-разрядные и 32-разрядные версии Android SDK ADT Bundle и 64-разрядные версии 32-разрядных версий Java SE. Я запускал AVD для 64-битной версии и в режиме совместимости с Windows 7. Я запустил AVD для 32-разрядной версии и с Windows XP (Service Pack 3) Режим совместимости. Окно эмулятора НЕ откроется. Когда я пытаюсь запустить из командной […]

Android @Suppress ошибки vs @TargetApi

Иногда я делаю код для определенных версий Android, который может запускать мое приложение. Eclipse с новейшими инструментами Android все еще замечает, что мой документ Manifest позволяет использовать более низкие версии Android и поэтому решает, что в моем коде есть ошибки. Решением этого является добавление тега @Suppress выше метода, чтобы он не сообщал об ошибке, или […]

Создание игровой силы тяжести в Android (продолжение)?

EDIT: я взглянул на LogCat, и он сказал, что он не может раздуть com.example.playground. Затем я понял, что мне это нужно для com.game.myapp.Playground. Он работал после того, как я изменил его. Недавно я спросил, почему гравитация не работает в моем приложении для Android ( ссылка ), и у меня все еще есть проблемы с этим. […]

Почему некоторые API Android не отображаются на вкладке «Целевая аудитория AVD»?

Я должен работать в среде, которая не имеет подключения к Интернету из-за соображений безопасности. Я загрузил последние API-интерфейсы и выполнил следующие шаги в следующем ответе: ..\adt-bundle-windows-x86\adt-bundle-windows-x86\sdk\platforms Обновите менеджер Android SDK без подключения к Интернету, но более раннюю загрузку для другого SDK Более того, я вижу API-интерфейсы в SDK-менеджере как установленные, когда я иду в AVD-менеджер, […]

Как использовать Android Design Pack от Google с помощью Eclipse

Я пытаюсь использовать эти классные дополнения, которые Google предоставляет в ссылке ниже http://developer.android.com/design/downloads/index.html Но я не могу понять, как интегрировать его с eclipse, чтобы они были доступны напрямую, как перетаскивание. У вас есть идеи, как его использовать?

Eclipse неправильно заявляет, что у меня есть старый Rev Android SDK

Просто, чтобы предисловие к этому, я искал высоко и низко в Интернете, пытаясь найти ответ на эту проблему и еще не нашел его, были люди с подобными проблемами, как я, но не совсем то же самое. Я пытаюсь настроить Eclipse на Android SDK. Сначала я установил Eclipse (Classic) и отредактировал файл .ini, чтобы найти правильный […]