Articles of eclipse

Режим отладки Android Eclipse – Темы

Один простой вопрос, я отлаживал свое приложение сегодня и впервые задал себе вопрос. В режиме отладки Eclipse у вас много опций и значений, но одно из них заставило меня немного поработать во время отладки. Все эти Threads на картинке, что они должны означать? Темы, которые работают в моем приложении? Темы, которые я запускаю / останавливаю, […]

NoClassDefFoundError разрабатывает библиотеку с Android-приложением, Maven и Eclipse

Я разрабатываю библиотеку Android ( SiriRestClient ), чьи артефакты управляются через Maven, и я использую Eclipse для разработки. Я собираю артефакты как файл JAR, так как у меня нет никаких активов в проекте, только классы Java, и есть проблемы с упаковкой артефактов в качестве апклибов с Eclipse / Maven / ADT . Я также разрабатываю […]

Невозможно импортировать ActionBar в Android-приложение с обратной совместимостью

У меня есть приложение для Android, которое предназначено для API 17 и имеет минимальную версию SDK версии 8. Я не заинтересован в предоставлении ActionBar на устройствах с Android API <11, но я бы хотел использовать на устройствах под управлением Android> = 3.0 , Просмотрев stackoverflow, чтобы узнать, как это сделать, я наткнулся на этот вопрос: […]

Почему «Атрибуты времени разработки» не работают?

Задний план Google добавил хорошие « атрибуты времени разработки » (найденные здесь ), которые будут использоваться только для режима пользовательского интерфейса, так, например, если вы хотите просто показать текст в текстовом виде (или EditText) (чтобы помочь вам понять, как Это похоже), вы можете просто добавить: <EditText tools:text="John Doe" android:layout_width="wrap_content" android:layout_height="wrap_content" /> Пример из Google: Фактически, […]

Импорт SDK в Facebook для Eclipse не может разрешить импорт java / Android

Я просто импортировал SDK для Facebook в Eclipse, но в проекте FacebookSDK есть некоторые ошибки, которые я не могу исправить. Проект в Project Explorer выглядит так Но когда я открываю файл, в этом случае AccessToken.java, он содержит все эти ошибки Когда я перемещаю курсор над этими ошибками, он говорит: «импорт … не может быть разрешен». […]

Не удалось открыть базу данных / Не удалось изменить локаль для (базы данных) на 'en_US'

Я прочитал решение от Не удалось изменить локаль для db '/data/data/my.easymedi.controller/databases/EasyMediInfo.db' в 'en_US', но это мне не помогает. У меня все еще такая же ошибка. Это мой класс DBHelper . Не могли бы вы заглянуть в нее и помочь мне? package com.example.mgr; import java.io.FileOutputStream; import java.io.IOException; import java.io.InputStream; import java.io.OutputStream; import java.sql.Date; import java.util.ArrayList; import […]

Eclipse не узнает мой Android-телефон – говорит неизвестный

Я использую ADT eclipse для разработки Android. Я подключил свой телефон, а затем затмевал. Затем, когда я запускаю свой проект андроида, я получаю окно с запросом, как вы хотите его запустить. Я вижу, что мой телефон указан там, но он не узнает его целевую версию. В результате я не могу запустить его на своем телефоне. […]

Библиотека поддержки Android Eclipse: обязательная версия пуста

Я только что загрузил и установил последний пакет ADT для Windows, доступный с веб-сайта разработчика Android. После этого я установил все пакеты в диспетчере SDK, в том числе «Библиотека поддержки Android Rev. 18». Наконец, я установил последний ADT через меню «Справка> Установить новое программное обеспечение …» в Eclipse. Я строго следовал следующему руководству, чтобы создать […]

Eclipse не создает проект Android, ориентированный на 5.0 Lollipop

Я обновил Android SDK с помощью менеджера SDK в Eclipse (Kepler). Когда я изменяю цель сборки на Android 5.0 Lollipop, Eclipse больше не создает проекты. После очистки проекта папка «gen» становится пустой, а R.java и другие файлы не генерируются снова, хотя у меня включена функция «Build Automatically». Выполнение «Build Project» или «Build All» вручную также […]

Переполнение буфера Eclipse Google Glass

Я видел все другие записи переполнения буфера, и я попробовал все, что они сказали. Дело в том, что я не на API 19, как и большинство людей, получающих ошибку. Я создаю стеклянную посуду для Google Glass, поэтому я нахожусь на API 15 (4.0.3). Почему я должен получать эту ошибку? [(timestamp) Dex Loader] Unable to execute […]

Intereting Posts