Articles of Android studio

Бесконечная Gradle Build Запуск Java 8

Я пытаюсь перейти с Java 7 на Java 8, поэтому я установил новый sdk для Android N и всех инструментов. Я следую руководству по разработке, чтобы использовать Java 8 в студии android , но когда я пытаюсь скомпилировать apk, у меня есть бесконечный Gradle Build Running. Я уже пытаюсь перезапустить Android Studio, но через 1 […]

Элементы атрибута ширины и высоты атрибута ограничения автоматически возвращаются к 0dp

Поэтому у меня есть эта странная и раздражающая проблема с макетами ограничений – некоторые из представлений в макете Constraint меняют ширину и высоту на 0dp из пользовательского значения БЕЗ КАКИХ-ЛИБО УВЕДОМЛЕНИЯ. Такое поведение несовместимо, потому что я буду строить свои макеты, я буду тестировать их, я буду счастлив и перейду к следующей вещи, но через […]

Запустить firebaseUploadReleaseProguardMapping из файла app / build.gradle

Есть ли способ запустить задачу gradle из файла app / build.gradle, так что когда я создам выпуск APK, задача «firebaseUploadReleaseProguardMapping» будет запускаться автоматически.

Как я могу связать родную библиотеку в Android Studio?

В настоящее время я использую библиотеку, которую я уже скомпилировал в .so файлы. Я поместил библиотеку в jniLibs и я загружаю ее с помощью: System.loadLibrary("library"); Теперь я хочу использовать эту библиотеку в своем собственном собственном коде, так как я могу связать эти .so файлы с моими собственными файлами из jni папки?

Ошибка Gradle в приложении: packageDebug, Android Studio, Ubuntu

Я пытаюсь запустить проект в Android Studio на Ubuntu, но он не работает со следующей ошибкой в ​​gradle. Error: Execution failed for task ':app:packageDebug'. > org/bouncycastle/util/Store Я использую Android Studio в Windows, но никогда не сталкивался с этой ошибкой. Я пытался это сделать, но это не сработало. Пожалуйста, помогите мне решить эту проблему.

Ошибка Android Studio JUNIT4 !!! Ожидается, что версия JUnit версии 3.8 или более поздней версии:

Я занимаюсь проектом Android (в Android Studio), с небольшим количеством SDK, который является чистым java. Так что я хочу сделать тест от JUnit4. И я сконфигурировал Gradlle File таким образом: apply plugin: 'android' android { compileSdkVersion "Google Inc.:Google APIs:19" buildToolsVersion "19.0.1" lintOptions{ checkReleaseBuilds false } defaultConfig { minSdkVersion 8 targetSdkVersion 19 versionCode 28 versionName "4.0.5" […]

Android, как изменить размер (масштаб) иконки вектора xml программно

Это сводит меня с ума. Я хотел бы иметь возможность изменять размер xml vector drawable icon программно, чтобы использовать его в ImageView. Это то, что я сделал до сих пор, что не работает Drawable drawable = ResourcesCompat.getDrawable(getResources(),R.drawable.ic_marker,null); drawable.setBounds(0,0,512,512); imageVenue.setImageDrawable(drawable); Значок вектора ic_marker не изменяется. Он просто сохраняет жестко кодированные значения ширины и высоты каждый раз. […]

Android Studio Gradle not Building Project

Я очень хорошо использовал свою андроид-студию. Я не знаю, что произошло, и теперь я получаю только информацию о проекте «xxxx» Gradle, когда хочу создать свой новый проект. Я не могу открыть какой-либо новый проект. Пожалуйста помоги. У меня нет даже 10 репутаций для загрузки скриншота. Я думаю, что мой Gradle не работает. Как я могу […]

Не удалось изменить устаревшую модернизацию

Это мой первый раз, когда я пытаюсь использовать gradle с проектом android. Я хотел бы добавить модификацию в свой проект, но он продолжает говорить мне. Не удалось решить: com.squareup.retrofit: retrofit: 1.9.0 Не удалось решить: com.squareup.okhttp: 2.2.0 Однако службы Google Play работают отлично. Мой файл градиента выглядит следующим образом: apply plugin: 'com.android.application' android { compileSdkVersion 21 […]

Android Studio создает вариант / тип сборки, исключая jniLibs?

У меня есть приложение для Android, которое использует собственную библиотеку JNI. Я положил его в app/src/main/jniLibs/armeabi-v7a без какой-либо конфигурации градиента, и студия Android радостно связывает ее с APK. У меня есть требование, когда все родные библиотеки не могут быть связаны с определенным дистрибутивом. Возможно ли создать вариант сборки или тип сборки, который просто исключает все […]