Articles of android studio 2.0

Предупреждение SVG-файла в редакторе Android Studio

Я использую Android Studio 2.0 с SVG2VectorDrawable: Если я открою файл svg для редактирования из папки ресурсов \RAW , файл i, подчеркнутый красным цветом, и предупреждающее сообщение «элемент svg должно быть объявлено», показано ниже: Что я могу сделать для решения этой проблемы? Я использую плагин SVG только для расширения редактора, который позволяет корректно просматривать формат […]

Gradle не удается синхронизировать мой проект в новом Android Studio 2.0

Я только что обновил (то есть установил полную новую версию) мою Android-студию с 1.5 до 2.0. Обновление, похоже, прошло гладко, но у меня возникают проблемы с моим проектом, когда я его открываю, когда Gradle синхронизирует мой проект. После синхронизации Gradle в течение нескольких минут я получаю эту ошибку: Failed to sync Gradle project MyProject Unknown […]

Проект Android-проекта успешно запущен, но сбой завершился с ошибкой: java.util.zip.ZipException: дублировать запись

Я обновляю свою студию Android и SDK и некоторые зависимости пакетов от уровня проекта, и с тех пор я столкнулся с большой проблемой, что, по моему мнению, причиной является несовместимость между зависимостями. Когда я исследовал, я обнаружил, что у многих людей одинаковые проблемы, и это не редкость. Я решил часть ошибки, но проблемы просто появляются […]

Android Studio 2.0 – NoSuchAlgorithmException: SHA256WITHDSA Подпись недоступна

Я запускаю Android Studio 2.0 Preview 3b и пытаюсь использовать «Generate Signed APK …» в меню « Построение» . Я получаю следующее сообщение об ошибке: :wear:packageRelease FAILED FAILURE: Build failed with an exception. * Exception is: org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':wear:packageRelease'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:69) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:46) … Error:org.gradle.tooling.BuildException: SHA256WITHDSA Signature not available: try using a […]

Ошибка: ваш процессор не поддерживает необходимые функции (vt-x или svm)

Я продолжаю получать ошибку, отмеченную выше, когда я пытаюсь запустить виртуальное устройство. Мой процессор поддерживает виртуализацию и включен. Раньше я запускал виртуальное устройство на затмении, но по какой-то причине Android Studio мне тяжело. Мой процессор – шестифазный процессор AMD FX 6350 3.90 Ghz, работающий под Windows 10.

Можно ли запустить эмулятор устройств Android (через Android Studio 2) на VMWare?

Я работал под управлением Android Studio 1.5.1, создавая версию WMWare для Windows 2012 R2, и все работает нормально. Я смог запустить эмулятор устройства без проблем и запустить различные версии Android, работающие в AVD. Android Studio 2.x Change Недавно я установил Android Studio 2.0 (см. Изображение ниже для точной версии). Теперь, когда я пытаюсь запустить эмулятор, […]

Android Studio: невозможно удалить исходный файл

Я очень новичок в Android, и я совсем недавно клонировал проект Android. Когда Android Studios выполняет индексирование после открытия проекта, я получаю эту ошибку все время. Это ошибка, которую я получаю от Android Studio. Error:(89, 0) Failed to delete original file 'C:\Users\myname\AppData\Local\Temp\gradle_download8065263342645015068bin' after copy to 'C:\Users\myname\.gradle\caches\modules-2\files-2.1\com.android.tools.build\gradle\1.5.0\1c3d2b23212349ffbe6479fcb04732c5cddaf98b\gradle-1.5.0.pom' <a href="openFile:D:\myname\mobile-myapp-tester\platforms\android\build.gradle">Open File</a>

Android Studio 2.0 запускает APK на другом устройстве

Начиная с Android Studio 2.0 и переработанного механизма сборки / запуска, я больше не могу запускать APK на втором устройстве. После того, как APK был загружен на первом устройстве, я не могу выбрать запуск сборки на другое устройство. «Запуск» будет нацелен на текущее устройство «Повторный запуск» остановит приложение, запущенное на текущем устройстве, и выведет его […]

Не удалось разрешить импорт из внешних зависимостей в Android Studio 2.0 Preview 5 + Preview 6

После обновления с последнего предварительного просмотра Android Studio 2.0 до Preview 5 у меня возникли проблемы с импортом из пакета android.support.wearable . Как основное приложение, так и приложение Wear строят и работают отлично, но редактор в Android Studio жалуется, что он не может разрешить эти импортные import android.support.wearable.activity.WearableActivity; import android.support.wearable.view.CircledImageView; import android.support.wearable.view.WearableListView; В build.gradle модуля […]

Требуется Gradle версия 2.10. Текущая версия 2.8 Ошибка

Следующие вещи используются в проекте – Версия для Android-версии – 2.0 Preview 4. ANDROID_BUILD_MIN_SDK_VERSION = 9 ANDROID_BUILD_TARGET_SDK_VERSION = 22 ANDROID_BUILD_TOOLS_VERSION = 22.0.1 ANDROID_BUILD_SDK_VERSION = 22 classpath 'com.android.tools.build:gradle:2.0.0-alpha9' В соответствии с ошибкой я изменил URL-адрес распространения https\://services.gradle.org/distributions/gradle-2.8-all.zip в https\://services.gradle.org/distributions/gradle-2.10-all.zip Но все еще получаю следующую ошибку Ошибка: (1, 1) Возникла проблема с оценкой проекта ': app'. Не […]