Articles of android manifest

Есть ли способ указать требования к архитектуре процессора в манифесте Android?

Я использую собственную библиотеку в моем проекте Android, который скомпилирован в armeabi-v7. Мой проект нацелен на Android SDK 8. Когда я пытаюсь запустить его с отключенным телефоном, автоматическое таргетинг выбирает виртуальное устройство Android 2.2 (armeabi) вместо 4.03 (armeabi-v7) и пытается установить его на этом, но это бросает Failed to install apk on device 'emulator! ошибка. […]

Разрешение отказа читать с emailprovider в android

У меня проблема, когда я хочу прочитать com.android.email.provider чтобы получить учетные записи электронной почты. Вот мой код для извлечения учетной записи: Cursor c = null; Uri CONTENT_URI = Uri.parse("content://com.android.email.provider/account"); String RECORD_ID = "_id"; String[] ID_PROJECTION = new String[] {RECORD_ID }; c = getContentResolver().query(CONTENT_URI,ID_PROJECTION,null, null, null); Я получил исключение безопасности: java.lang.SecurityException: Permission Denial: reading com.android.email.provider.EmailProvider uri […]

Android-сборка не позволяет получить все доступные версии «VERSION_CODES»

В настоящее время я работаю над android, я использую инструмент eclipse. Поскольку я хотел получить список всех версий android version_Codes, доступных для проекта. Но в настоящее время мой инструмент / eclipse показывает только версии_кодов до Froyo. Я добавил минимальное значение sdk для android для 8 и целевое значение sdk равно 17. У меня есть мой […]

Android-приложение не запускается в более низкой версии, чем targetSDKVersion

Я только что загрузил последнюю версию SDK из Android SDK Manager и установил целевой объект Project для Google Project на уровне 17 API ниже. И добавлен в AndroidManifest.xml моего приложения, как показано ниже. <uses-sdk android:minSdkVersion="3" android:targetSdkVersion="17" android:maxSdkVersion="17" /> И загрузил эмулятор с уровня 8, 2.2, затем попытался запустить приложение на этом эмуляторе. Всякий раз, когда […]

Программно получить разрешения от manifest.xml в android

Я должен программно получить разрешения из manifest.xml приложения android, и я не знаю, как это сделать. Я прочитал сообщение здесь, но я не полностью удовлетворен ответами. Я предполагаю, что в API андроида должен быть класс, который позволит извлекать информацию из манифеста. Спасибо.

Добавление разрешений к манифесту приложения программно

Я пытаюсь добавить разрешения в свой манифест приложения, чтобы он мог получить доступ к другим приложениям, которые пользователь устанавливает во время выполнения. Я думал, что для этого нужно определить дерево разрешений в манифесте, а затем использовать PackageManager.addPermission () для добавления разрешений под этим деревом. Однако я не могу заставить это работать, и документация, которую я […]

Как найти источник разрешения в Unity Android

Примечание. Этот вопрос относится только к Unity3D У меня есть очень чистый файл манифеста Android в проекте Unity в папке Plugins/Android/ без тегов <uses-permissions/> . Я считаю, что некоторые разрешения в конечном APK поступают из настроек Android Player для примера READ_EXTERNAL_STORAGE . В моем проекте Gear VR я вижу следующие строки, добавленные в итоговый манифест, […]

Использование разрешений, которые Android 2.1 не знает (на Android 2.1)

В настоящее время я разрабатываю приложение, которое извлекает данные с сервера с определенным интервалом. Я понимаю, что это не самый эффективный способ, поскольку он часто будет опросить сервер без получения каких-либо новых данных. Решением для этого было бы использование C2DM, и в настоящее время я изучаю, как это установить. Однако около 7% моих пользователей по-прежнему […]

Как изменить группу пользователей приложения

У меня есть приложение, которое должно быть частью группы, то есть группы аудио. По умолчанию приложение получает группу владельца, когда оно установлено. Скажем, мой владелец приложения – app_46 и группа app_46. Как я могу изменить группу приложения на аудио или что-то еще во время выполнения? Есть ли какие-либо разрешения или что-то в AndroidManifest.xml?

Разный выход в Android 4.1

Я запустил свою программу на Android 2.3 и Android 4.1, но изображения моего приложения показали очень малое в android 4.1: Я <uses-sdk android:minSdkVersion="5" android:targetSdkVersion="14" /> в manifest.xml и мое приложение отлично работает на обоих: Но я не хочу удалять <uses-sdk android:minSdkVersion="5" android:targetSdkVersion="14" /> Где моя проблема? Аннотация моего кода: public class MapCanvas extends ImageView { […]